[Serveur apache] Configurer avec routeur [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
samedi 29 novembre 2003
Statut
Membre
Dernière intervention
11 avril 2008
-
 ld -
Bonjour,

j'ai installé wamp et j'ai quasi rien touché au httpd.conf
J'ai juste rajouté :

Listen 192.168.1.133:80


et d'ailleurs je sais pas si c'est necessaire mais en tout cas sans ça si je fais http://192.168.1.133/ il ne se passe rien

J'ai aussi forwardé le port 80 vers le poste 192.168.1.133 (je sais me servir du routeur, les autres redirection que j'ai faites marchent bien)

Mais malgré ça mon serveur n'est visible qu'en Intranet, l'exterieur me voit pas.

J'ai fais le test en virant le routeur et en connectant directement et j'ai modifié le Listen en mettant monip:80 et ça marche

Donc que faut il faire a part les redirections pour qu'un serveur web soit visible de l'extérieur s'il est derriere un routeur.
Lorsque je tape https://www.xxx.xxx/ (mon ip) ça marche si j'enleve le routeur, mais ça ne marche pas avec le routeur. Que faut il mettre dans le httpd.conf ?

Merci

2 réponses

Messages postés
26
Date d'inscription
mardi 7 mars 2006
Statut
Membre
Dernière intervention
8 décembre 2008
3
DMZ Host

The DMZ Host setting can allow one local PC to be exposed to the Internet. If a local user wishes to use some special-purpose service such as an Internet game or video-conferencing, Enable DMZ, fill in the IP address, and click the Save Settings button. Select Disable for DMZ, deactivates this feature. When enabling this setting, the Router firewall protection of the local DMZ host will be disabled.

tu doit donc activer DMZ dans ton routeur. il s'agit d'une addresse ip de ton sous reseau qui va etre exposé a internet. donc tu doit choisir l'addresse ip de la machine serveur web.

pas la peine de modifier le paramtre listen dans le fichier httpd.conf
Messages postés
19
Date d'inscription
samedi 29 novembre 2003
Statut
Membre
Dernière intervention
11 avril 2008
8
Merci pour la reponse. ça marche
moi je suis dans le meme cas mé ca marche pas :( j'ai fait dmz et tout mais ca marche pas :(