Problème de tri dans Excel

Résolu/Fermé
Signaler
-
 Catherine -
Bonjour,

J'ai une colonne avec des références EUxxxx et depuis que j'ai rajouté un chiffre donc : EUxxxxx, j'ai un problème de tri :
Exemple, EU9999 arrive après EU10001 et non pas avant alors qu'il n'y a que 4 chiffres après EU.
J'ai essayé en transformant ces références avec un tiret (EU-xxxx et EU-xxxxx) mais ça ne marche pas mieux.
Merci d'avance pour votre aide,
Cordialement,
Catherine



3 réponses

Messages postés
96
Date d'inscription
lundi 23 octobre 2006
Statut
Membre
Dernière intervention
6 mai 2011
34
essaie en mettant EU09999
0
Super PtiSwiss, ça marche ! Par contre, j'ai environ 1000 lignes....une idée de formule ou de format peut être ?....
Merci
Catherine
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
Une formule peut être
en commençant en A1:
=SI(NBCAR(A1)=7;A1;SUBSTITUE(A1;"EU";"EU0";1))
qui rajoute un 0 derrière EU quand les codes n'ont que 6 caractères?

à appliquer dans une colonne libre et copier coller valeur sur la colonne d'origine.

crdlmnt
0
Génial ! C'est exactement la formule qu'il me fallait et ça marche super !
Merci encore !
0
Messages postés
96
Date d'inscription
lundi 23 octobre 2006
Statut
Membre
Dernière intervention
6 mai 2011
34
re

non pas la mais le plus simple reste ctrl+f / remplacer EU9 par EU09 EU8 par EU08 ect ....

tiens moi au courant
0