Aide excel formule

Résolu/Fermé
FP - 24 mars 2011 à 12:44
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 - 24 mars 2011 à 19:57
Bonjour,

je bloque sur une formule qui parait simple et que je souhaite insérer. si vous pouviez donc m'éclairer :

A1 : valeur à entrer x
A2 : résultat

Je veux que le résultat qui s'affiche en A2 soit un nombre qui prend en compte ces critères :
Si 0<x<9,99 alors le résultat est 10
Si 10<x<19,99 alors le résultat est 20
Si 20<x<29,99 alors le résultat est 30
Si 30<x alors le résultat est 40

voila, j'espère que vous saurez trouver cette formule de base. Merci par avance
A voir également:

3 réponses

xkristi Messages postés 4264 Date d'inscription lundi 18 décembre 2006 Statut Membre Dernière intervention 19 août 2022 564
24 mars 2011 à 13:06
Salut Vaucluse !

Tu as fait plus vite que moi !!! lol

SI(A1=0;0;SI(ET(A1>0;A1<10);10;SI(A1<20;20;SI(A1<30;30;SI(A1<30;30;40)))))

valeur de A1=0 tu as 0

(petite erreur dans l' énoncé donné
Si 30<x alors le résultat est 40)
1
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 404
Modifié par Vaucluse le 24/03/2011 à 17:01
Bonjour Xkristi..

.. ça fait plaisir de temps de temps, d'autant plus que tu es plus précise et plus judicieuse que moi dans le choix des limites, je m'en suis tenu strictement à l'énoncé.
Ta proposition est bien plus logique, et équivaut cette fois à ARRONDI.SUP; -1
Par contre, je ne sais pas l'utilité du ET dans le second SI. J'aurais compris dans le premier, pour éliminer aussi d'éventuelles valeurs négatives (?) soit >(SI(ET(A1=0;A1<0);0

mais là je ne vois pas.

Au plaisir

bien amicalement
0
xkristi Messages postés 4264 Date d'inscription lundi 18 décembre 2006 Statut Membre Dernière intervention 19 août 2022 564
24 mars 2011 à 19:14
Ho non , suis pas plus judicieuse et pas plus précise que toi
d'autant que je n'ai rien expliqué

le ET dans le second SI de ne pas prendre en compte des valeurs négatives
(si elles existaient)
Par contre la redite du dernier SI ne se justifie pas
SI(A1=0;0;SI(ET(A1>0;A1<10);10;SI(A1<20;20;SI(A1<30;30;SI(A1<30;30;40)))))

dans l'optique où il ne veut avoir en valeur maxi que 40 c'est :
SI(A1=0;0;SI(ET(A1>0;A1<10);10;SI(A1<20;20;SI(A1<30;30;40))))
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 404
Modifié par Vaucluse le 24/03/2011 à 19:57
OK Xkristi, reste que là où est ton ensemble ET(SI....), les valeurs négatives seront prises en compte dans les suivants car il n'applique qu'à <10;
C'est pour ça que je le verrais mieux dans le premier.
mais tout ça, c'est de la polémique
Bonne soirée et au plaisir , n'attend pas trop pour nous revenir
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 404
Modifié par Vaucluse le 24/03/2011 à 13:00
Bonjour
=SI(A1<9,99;10;SI(A1<19,99;20;SI(A1<29,99;30;SI(X>30;40;""))))
attention, affiche 10 si A1=0
pour éviter ça si besoin:
=SI(A1=0;0;SI(A1<9,99;10;SI(A1<19,99;20;SI(A1<29,99;30;40))))

ou aussi plus simplement, à vérifier selon vos cas de figure:
=ARRONDI.SUP(A1;-1)

qui arrondi directement toute valeur à la dizaine supérieure
crdlmnt


Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
0
Merci beaucoup pour vos réponses ultra rapides. Effectivement il y avait une petite erreur dans mon énoncé sur le dernier critères.
0