Remplacer une lettre en chiffres excel

Résolu/Fermé
Floretteuh - 14 mars 2011 à 10:07
tchernosplif Messages postés 600 Date d'inscription dimanche 8 novembre 2009 Statut Membre Dernière intervention 21 juin 2015 - 14 mars 2011 à 16:28
Bonjour,

Je me permets de vous soliciter car j'ai un problème, qui je pense n'est pas treès compliqué, mais qui me fait perdre énormément de temps.
Voila je suis sous Excel 2003, j'aimerais que lorsque je tape A dans une case il me donne la valeur 5, puis dans une autre case A doit se transformer en 1 ...
Y a t'il une formule spéciale pour faire cela?

Merci d'avance
Flore

1 réponse

tchernosplif Messages postés 600 Date d'inscription dimanche 8 novembre 2009 Statut Membre Dernière intervention 21 juin 2015 241
14 mars 2011 à 11:47
Bonjour Florette,

2 possibilités:

nommer une cellule A ;si cette cellule contient 5, alors dans une autre cellule écrire =A revient à écrire 5.

Sinon il y a la formule substitue pour remplacer des caractères, celà nécessite d'écrire la formule.

=SUBSTITUE(A1;"A";"5")
si en A1: TATA => T5T5
2
Merci pour la réponse, la formule =SUBSTITUE(A1;"A";"5") est exactement ce que je recherchais, mais du coup ca me soulève un autre problème: le A se transforme en 5 dans la logne que j'ai besoin mais lorsque je fais la somme de sa colone le 5 n'est pas pris en considération dans le calcul de la somme ...
0
michel_m Messages postés 16589 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 12 janvier 2023 3 289
14 mars 2011 à 14:23
Bonjour
=SI(A1<>"A";"";CNUM(SUBSTITUE(A1;"A";"5")))
0
Parfait merci :)
[ Heureusement qu'il y a des gens comme vous pour aider des gens comme moi ]
0
tchernosplif Messages postés 600 Date d'inscription dimanche 8 novembre 2009 Statut Membre Dernière intervention 21 juin 2015 241
14 mars 2011 à 16:28
oui parce que le chiffre est considéré comme du texte, il faut le multiplier par 1 pour le transformer en nombre.
0