EXCEL- Imbrication RECHERCHEV + conditions

Résolu/Fermé
django972 Messages postés 2 Date d'inscription dimanche 13 mars 2011 Statut Membre Dernière intervention 13 mars 2011 - 13 mars 2011 à 01:12
django972 Messages postés 2 Date d'inscription dimanche 13 mars 2011 Statut Membre Dernière intervention 13 mars 2011 - 13 mars 2011 à 16:57
Bonjour,

Salut tout le monde. Petite question : est-ce qu'on peut utiliser des formules avec conditions et plusieurs recherchev.

Voici un exemple pour essayer d'être plus clair : =si(ET(RECHERCHEV(B3;'AE Melchior'!A8:AJ109;11)=RECHERCHEV(B3;'AE Melchior'!A8:AJ109;36));RECHERCHEV(B3;'AE Melchior'!A8:AJ109;11);Z3)

Je demande ça parce que j'ai utiliser cette formule dans un fichier excel, et qu'il me dit qu'il y a une erreur.

A voir également:

3 réponses

Ricky38 Messages postés 4347 Date d'inscription samedi 15 mars 2008 Statut Contributeur Dernière intervention 2 novembre 2013 1 450
13 mars 2011 à 01:58
Salut,

et si tu essayais ceci

=SI(RECHERCHEV(B3;'AE Melchior'!A8:AJ109;11)=RECHERCHEV(B3;'AE Melchior'!A8:AJ109;36);RECHERCHEV(B3;'AE Melchior'!A8:AJ109;11);Z3)

0
Raymond PENTIER Messages postés 56979 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 26 janvier 2023 17 174
13 mars 2011 à 02:15
Absolument ! Pour simplifier l'écriture (et la lecture) de la formule, je commencerais par donner à la plage A8:AJ109 de la feuille AE Melchior le nom "Matrice" :

=SI(RECHERCHEV(B3;Matrice;11)=RECHERCHEV(B3;Matrice;36);
RECHERCHEV(B3;Matrice;11);Z3)

... et par précaution j'ajouterais FAUX partout :

=SI(RECHERCHEV(B3;Matrice;11;FAUX)=RECHERCHEV(B3;Matrice;36;FAUX);
RECHERCHEV(B3;Matrice;11);Z3;FAUX)

Cordialement.
0
django972 Messages postés 2 Date d'inscription dimanche 13 mars 2011 Statut Membre Dernière intervention 13 mars 2011
13 mars 2011 à 16:57
Bonjour

Merci Ricky et Raymond. Ca marche nickel, merci pour vos conseil.

Tchuss
0