Taux de présence planning personnel - EXCEL [Résolu/Fermé]

Signaler
Messages postés
28
Date d'inscription
samedi 12 mars 2005
Statut
Membre
Dernière intervention
22 novembre 2012
-
 grisbi71 -
Bonjour,

Je suis en train de réaliser un planning pour gérer le personnel de mon entreprise sous feuille excel.
Je souhaite connaitre la raison de l'absence
C pour Congés payés ou RTT
A pour autre absence : maladie, temps partiel...
"Vide" pour Présence

Chaque employé complète pour le trimestre les raisons de son absence.

Je souhaiterai insérer une formule excel pour calculer le taux de présence journalier.
Ainsi, si C, alors 0
si A, alors 0
si "vide", alors 1

pour au final faire un pourcentage du taux de présence pour X salarié... et ce pour plusieurs services.

Le tableau se présente ainsi (je n'arrive pas à faire un coller de l'aperçu) :

Mois de Juin 01 02 03
Employé 1 C C C
Employé 2
Employé 3 A

Taux de présence

Quelqu'un pourrait-il m'aider ?
Comment dois-je composer la formule ?

Merci par avance





4 réponses

Messages postés
25369
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 521
Bonjour:

Je ne vois pas très bien par rapport à quoi vous voulez un taux de présence, mais peut être qu'avec quelques info vous pourrez adapter votre sujet:
en colonne ,en ligne ou dans un tableau complet:
=NB.SI(Champ;"<>") vous donne le nombre de cellule non vide
=NB.SI(Champ;"A") vous donne le nombre de A
=NB.SI(Champ;"C") vous donne le nombre de code C dans le champ

Etc...
revenez si besoin en mettant votre modèle sur:
http://www.cijoint.fr et en revenant placer le lien donné par le site.
crdlmnt


1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
28
Date d'inscription
samedi 12 mars 2005
Statut
Membre
Dernière intervention
22 novembre 2012

Merci pour ton aide

J'ai essayé d'appliquer la formule pour le calcul de cellule non vide, cela me met une erreur.

Mais en fait, ce qu'il me faudrait, c'est une formule pour le calcul des cellules vides. Est-ce que ce serait : =NB.SI(Champ;"") ?

Je mets ci-après le lien pour mon fichier :
tp://www.cijoint.fr/cjlink.php?file=cj201103/cijv2c3rLP.xls

Je ne m'y connais franchement pas trop pour les formules.
Merci de m'aider
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 293
change ton champ par H10:H17

donc =NB.SI(H10:H17;"<>")/8
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 293
Salut,

je ne sais pas si j'ai bien compris ton problème mais je t'ai fait un petit exemple
http://www.cijoint.fr/cjlink.php?file=cj201103/cijwS8kfea.xls

On peut surement faire plus simple.

P.S. pour mettre ton fichier tu vas sut http://cijoint.fr , tu déposes ton fichier et tu nous colles le lien généré ici.

Merci
Messages postés
28
Date d'inscription
samedi 12 mars 2005
Statut
Membre
Dernière intervention
22 novembre 2012

Merci RIcky38

Tu as bien compris mon problème. Juste que je trouve préférable de compter les lignes où rien n'est mentionné (donc où le personnel est sensé être présent).
Ca donne donc :
=NB.SI(H10:H17;"")
Ensuite je fais une ligne du nombre de présents (que je masque) et je fais une nouvelle ligne taux de présence avec mon pourcentage de présents sur le nombre total.

Juste un problème : si ma plage de données est fractionnée, ce qui est le cas, je fais comment ???
c'est par exemple H10:H14 et H16:H17

Tu aurais une suggestion ?

Merci encore
Messages postés
52430
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
14 279
= NB.SI(H10:H14;"") + NB.SI(H16:H17;"")
Messages postés
28
Date d'inscription
samedi 12 mars 2005
Statut
Membre
Dernière intervention
22 novembre 2012

Finalement, c'est bien cette formule qu'il faut insérer.

Merci Vaucluse pour ton aide.

Si je veux perfectionner la cellule "taux de présence" et que celle-ci soit indiquée en vert si le taux est supérieur à 50 et en rouge si le taux est inférieur à 50, comment dois-je pratiquer ?

Je sais qu'il existe une formule, mais laquelle ???

Merci si tu peux me renseigner.
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 293
mise en forme conditionnelle
Messages postés
16232
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 octobre 2020
3 047
bonjour à tous

Juste au passage pour compter les vides, il existe la fonction NB.VIDE