[EXCEL] Calcul statistiques

Résolu/Fermé
Signaler
Messages postés
4
Date d'inscription
lundi 9 août 2010
Statut
Membre
Dernière intervention
10 mars 2011
-
Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
-
Bonjour,

Admettons que j'ai une colonne avec 35 lignes dont certaines sont colorées. J'aimerais calculer de manière automatique le pourcentage de cellules colorées par colonne. Si avec les couleurs c'est pas possible, je peux mettre des croix.
Comment je peux faire ?

Merci

2 réponses

Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
350
Il n'existe pas à ma connaissance de formule excel qui prenne en compte la couleur des cellules.
Il faudrait alors passer par des macros.

Qu'entendez-vous par "Si avec les couleurs c'est pas possible, je peux mettre des croix" ? Est-ce que ces cellules ne sont que colorées et n'ont pas de données ?
Dans ce cas, vous pouvez mettre une croix dans vos cellules et compter le nombre de cellules avec un croix comme ceci :
=NB.SI(A3:A100;"X") où A3 à A100 représentent la zone de saisie de la colonne A.
Vous pouvez aussi mettre n'importe quel caractère ou chiffre et compter simplement le nombre de cellules non vides comme ceci :
=NBVAL(A3:A100)

Michel
0
Messages postés
4
Date d'inscription
lundi 9 août 2010
Statut
Membre
Dernière intervention
10 mars 2011

Merci, et est-ce que c'est possible d'avoir un pourcentage automatique des cellules qui ont un caractère par rapport au nombre total de cellule ? Par exemple au lieu d'avoir 4 dans ma cellule "résultat", avoir 13 (si j'ai 4 cellules avec un caractère sur total cellules = 30)
0
Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
350
Bien sûr ! Mettre la formule suivante :
=NBVAL(A3:A100)/LIGNES(A3:A100)
Il faut mettre bien entendu la cellule au format %

Michel
0
Messages postés
4
Date d'inscription
lundi 9 août 2010
Statut
Membre
Dernière intervention
10 mars 2011

ca marche très bien comme ca!! Merci !
0
Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
350
Une astuce si vous voulez colorer automatiquement vos cellules dans lesquelles vous avez saisi quelque chose, c'est d'utiliser la mise en forme conditionnelle.
Si votre cellule est vide, pas de couleur et si elle n'est pas vide, mise en couleur.
Voici comment.
En supposant que votre plage de données se trouve de A1 à Z45, vous sélectionnez toute la zone en commençant par la cellule A1 jusqu'à Z45, puis vous allez dans Format/Mise en forme conditionnelle.
Vous choisissez "la formule est" et vous copiez/collez cette formule :
=SI(ESTVIDE(A1);"Faux";"Vrai")
Vous choisissez la couleur du texte et du fond que vous souhaitez (si ce que vous entrez dans vos cellules n'a pas d'importance, vous pouvez choisir la même couleur pour le fond et le texte)
et vous validez.
Dès qu'une cellule ne sera pas vide, elle se colorera automatiquement.

Michel
0