Macro tri Excel

[Résolu/Fermé]
Signaler
-
 Algo -
Bonjour,

Dans le cadre de mon emploi, je suis amené à utiliser beaucoup de données sur Excel.
Je souhaiterais savoir si vous connaissez une macro automatique ou non qui me permettrait de gérer mes données :
J'ai une colonne remplie de 0 et 1 à parcourir et je dois compter le nombre de passage de 0 à 1. Je souhaiterais en parcourant cette colonne incrémenter une cellule qui me donne le chiffre correspondant aux alternances 0/1 afin de le récuperer.
Merci de votre aide

3 réponses

Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
623
Bonjour,

C'est faisable sans VBA.

Si la colonne est en A par exemple et commence en A1.

Prendre la colonne B

en B1 mettre 0
en B2 mettre la formule : =SI(ET(A2=1;A1=0);B1+1;B1)

et tirer vers le bas la formule

La valeur cherchée est le MAX de la colonne B (c'est aussi la dernière cellule en B)

A+
Messages postés
24200
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
6 934
Bonsoir,

ou bien sur une seule formule :
=SOMMEPROD((A1:A199<A2:A200)*1)

Attention : les 2 plages de même longueur sont décalées d'une cellule.

eric
Je vous remercie pour vos réponses rapides !
A+