Comment exclure une valeur #DIV/0 [Fermé]

Signaler
-
 BRRR -
Bonjour,

Je tente de créer une formule Excel pour connaitre la moyenne des cases A,B,C. Malheureusement ces trois cases sont déjà sous forme de formule et il est possible que l'une d'elle renvoie une erreur de division par 0 de temps à autre.

Existe-t-il une façon de contourner le problème en excluant automatiquement la case qui renvoie une erreur?

Merci de votre aide
Mike V.

1 réponse

Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
613
Bonjour,

Je propose une solution en utilisant une formule matricielle :

{=SOMME(SI(ESTERREUR(A1:C1);0;A1:C1))/SOMME(SI(ESTERREUR(A1:C1);0;1))}

Il faut taper la formule normalement puis valider en faisant <Ctrl><Maj><Entrée> simultanément. Ainsi les accolades apparaissent.


Dans cet exemple on calcule la moyenne des trois cellules A1,B1,C1 en excluant celles qui sont en erreur. Si une cellule est en erreur, la moyenne est calculée sur les 2 autres.


Voila je n'ai pas trouvé plus simple.


EDIT : j'ajoute qu'il est plus simple d'empêcher de DIV/0 à la source en modifiant les formules dans les cases A,B,C selon ce principe :

=SI(Dénominateur<>0;Formule;"")

Ainsi la fonction MOYENNE(A1:C1) fonctionnera


A+
Cordialement,
3
Merci

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez Comment Ça Marche

CCM 65492 internautes nous ont dit merci ce mois-ci


Merci Pilas 31 : tu es mon héros.
Beaucoup de réponses trouvées ... mais la tienne est la bonne en ce qui me concerne :)