Incrémenter une condition sous excel 2007 [Résolu/Fermé]

Signaler
Messages postés
59
Date d'inscription
vendredi 11 février 2011
Statut
Membre
Dernière intervention
27 octobre 2011
-
Messages postés
8269
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
26 novembre 2020
-
Bonjour,


j'aimerai savoir s'il existe une maniere à faire incrementer une condition dans une formule .

ma formule est : SOMME.SI("A1,12";"=1";"F1,F12"),
je veux que la valeur 1 soit incrémenter à chaque fois que je glisse sur les autres cellules ..

cordialemnt

2 réponses

Messages postés
8269
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
26 novembre 2020
1 531
Bonjour,

Ta formule ne serait-elle pas plutôt :
=SOMME.SI(A1:A12;"=1";F1:F13)

Si c'est le cas tu peux essayer :
=SOMME.SI($A$1:$A$12;"="&LIGNE(A1);$F$1:$F$13)
que tu peux tirer vers le bas.
Messages postés
59
Date d'inscription
vendredi 11 février 2011
Statut
Membre
Dernière intervention
27 octobre 2011
2
Bonjour , pardon je te répond en retard , et merci pour ta réponse ,
juste la condition que je souhaite l'incrementer est une valeur "1" que je la précise dans ma , tu sais bien en programmation on fait 1++ par exemple pour incrementer de 1 ... alors pensez vous qu'il y'a une methode à faire l'affaire ?
cordialement .
Messages postés
25620
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 novembre 2020
5 626
Bonjour

c'st surtout votre formule et cette poignée de guillemets que l'on ne comprend pas

s'il s'agit de faire la somme de F1:F13 selon que A1:A12, il y a déjà un premier problème entre la ligne 12 et la ligne 13 (?)
ensuite les limites de champs ne se mettent pas entre guillemets, pas plus que les valeurs:
1La formule de Patrice est quasiment bonne, sauf les guillemets:
=SOMME.SI($A$1:$A$12;LIGNE(A1);$F$1:$F$12)
vous donnera placée n'importe où, le total de F lorsque A est égal à 1
en tirant vers le bas, vous aurez le total de F quand A =2 =3 ainsi de suite.
si ce n'est pas ce que vous voulez, votre question est mal posée.

crdlmnt
Messages postés
59
Date d'inscription
vendredi 11 février 2011
Statut
Membre
Dernière intervention
27 octobre 2011
2
BONSOIR , oui oui j'ai juste donner un exemple pour ma fonction , et j'ai pas fait attention aux fautes commises .....

a part ça , ça marche votre formule , merciii beaucoupppppp ......................merci , mercii
Messages postés
8269
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
26 novembre 2020
1 531
Bonjour Vaucluse

Ma formule fonctionne aussi, j'ai volontairement ajoutée "="& dans le critère pour rester généraliste et montrer qu'outre une valeur égale, il est aussi possible d'utiliser le critère différent de (avec "<>"&) ou tout simplement supérieur (avec ">"&).

cordialement
Patrice