Excel regrouper valeurs de 2 feuilles en une

[Résolu/Fermé]
Signaler
Messages postés
226
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
27 janvier 2013
-
Messages postés
226
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
27 janvier 2013
-
Bonjour,

J'ai 2 feuilles Excel (2007), du type de l'exemple ci-dessous :

Feuille 1 :
IndexP | Nom | Prénom
127 | Dujardin | Jean
362 | Youn | Michaël
401 | Elmaleh | Gad
695 | Boon | Dany
........

Feuille 2 :
Index | Score
127 | 220pts
401 | 180pts
695 | 520pts
.........

Les deux feuilles sont triées avec l'Index du plus petit au plus grand, mais dans chacune des feuilles, il se peut que certains index ne soient pas présents. On remarque ici que dans la feuille 2, l'index 362 n'existe pas.

Ce que je veux, c'est créer une nouvelle feuille regroupant toutes les colonnes avec les scores associés au bon Index, comme ci-dessous :

Feuille 3 :
127 | Dujardin | Jean | 220
362 | Youn | Michaël
401 | Elmaleh | Gad | 180
695 | Boon | Dany | 520

Comment puis-je faire ça ? J'ai regardé avec les tableaux croisés dynamiques, mais lorsque j'insère les 2 colonnes Index, ces dernières ne s'accordent pas ensemble, ce qui me donne :
127 | Dujardin | Jean | 220pts
362 | Youn | Michaël | 180pts
401 | Elmaleh | Gad | 520pts
695 | Boon | Dany

Merci d'avance pour votre aide.

5 réponses

Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Bonjour
en supposant que vos données soient en colonne A,B,C sur feuille 1 et 2

dans votre nouvelle feuille, pour l'exemple à adapter:

en ligne 1 les titres
colonne A>
INDEX (à entrer manuellement ou à copier depuis une des deux feuilles.)

en B2:
=SI(OU(ESTVIDE($A2);NB.SI(Feuil1!$A:$A;$A2)=0;"";RECHERCHEV($A2;Feuil1!$A:$C;2;0))
en C2
=SI(OU(ESTVIDE($A2);NB.SI(Feuil1!$A:$A;$A2)=0;"";RECHERCHEV($A2;Feuil1!$A:$C;3;0))
en D2
=SI(OU(ESTVIDE($A2);NB.SI(Feuil2!$A:$A;$A2)=0;"";RECHERCHEV($A2;Feuil2!$A:$C;2;0))
et tirez l'ensemble vers le bas sur la hauteur voulue.

attention aux libellés et au blocage

Feuil1! et Feuil2! sont bien entendu les noms de vos feuilles.
si jamais ces noms d'onglets comportent des blancs, il faut encadrer dans les formules avec des apostrophes:
feuil1! devient 'feuil1'!

crdlmnt



Messages postés
226
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
27 janvier 2013
16
merci pour votre réponse.
Il doit manquer une parenthèse pour chacune de vos formules, mais même en la rajoutant, il me dit erreur dans la formule. J'ai bien modifié le nom des feuilles.
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
effectivement, il manque un parenthèse, mais ce n'est pas à la fin, c'est après le =0
=SI(OU(ESTVIDE($A2);NB.SI(Feuil1!$A:$A;$A2)=0);"";RECHERCHEV($A2;Feuil1!$A:$C;2;0))

avec mes excuses

crdlmnt
Messages postés
226
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
27 janvier 2013
16
Merci beaucoup, c'est super, ça fonctionne parfaitement ! encore merci !!
Messages postés
226
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
27 janvier 2013
16
bonsoir.
je dois faire le même type d'exercice que précédemment, mais là :

je veux comparer la colonne F de ma feuil1 avec la colonne S de ma feuil2,

et si les 2 valeurs correspondent, je veux copier la cellule correspondante de la colonne Q de ma feuil2 vers la cellule de la colonne G de ma feuil1.

mais je n'arrive pas à arranger la formule que vous m'avez donné. pourriez-vous m'aider svp ?
merci :)
Messages postés
226
Date d'inscription
samedi 17 février 2007
Statut
Membre
Dernière intervention
27 janvier 2013
16
ok en faite c'est bon :)
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Bonsoir
besoin de quelques précisions:
comparer colonne F feuil1 et colonne S feuil2
faut il analyser les champ pour savoir si une valeur de l'une est dans l'autre,ou simplement comparer cellule à cellule.

C'est à dire est ce qu'il faut éditer Fx si Fx est n'importe où dans la colonne S
dans ce cas:
=SI(NB.SI(feuil2!S:S;feuil1!F1)>0;RECHERCHEV(F1;feuil2!$F$1:$G$5000;2;0);"")

Ou faut il éviter F1 s'il est égal à S1 F2 à S2 ect...,
dans ce dernier cas seulement:
=SI(feuil1!F1=feuil2!S1;RECHERCHEV(F1;feuil2!$F$1:$G$5000;2;0);"")

Mais je ne suis pas sur d'avoir bien compris


a vous lire

crdlmnt







Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?