Excel valeurs négatives d'une colonne à zéro [Résolu/Fermé]

Signaler
-
Messages postés
52293
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
-
Bonjour,

J'ai une colonne excel contenant des valeurs négatives, je veux mettre ces valeurs à zéro et garder les autres valeurs positives ou nulles sans changement.

Merci

5 réponses

Merci pour votre réponse, mais je ne sais pas comment l'utiliser.
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60835 internautes nous ont dit merci ce mois-ci

=SI(résultat<0;0;résultat)
Il suffit juste de remplacer résultat par le calcul que tu fais pour trouver cet valeur négative si c'est pas un calcul tu mets uniquement la cellule correspondante,

Tu comprends ?
Rebonjour,

A chaque fois que je remplace "résultat" par la cellule correspondante, je rçois un message "la formule que vous avez tapée contient une erreur". Je ne sais pas si la syntaxe est bien écrite.

Ma colonne contient plus de 900 cellules et je dois toutes les vérifier.

Exemple :
2,633
2,773
-2,065
2,016
1,498
1,308
-3,136
-3,662
-3,164
-3,718
-4,181
4,672
-4,552

J'écris =SI(A1<0;0;A1)
Messages postés
25299
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 481
Bonsoir
Lentz a donné la bonne solution. Pouvez vous mettre dans un prochain message la formule telle que vous l'écrivez?
crdlmnt
Messages postés
52293
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 septembre 2020
14 084
Bonjour Vaucluse ; bonjour Lentz.

Pour vous c'est évident que la formule doit se mettre dans la colonne voisine, mais kamyac ne l'a pas forcément réalisé ; alors je reprends par le détail :

En supposant que
2,633 soit en A2,
2,773 soit en A3,
-2,065 soit en A4,
2,016 soit en A5 etc.
il faut saisir en B2 la formule =SI(A2<0;0;A2) et recopier cette formule vers le bas (jusqu'à la cellule B901).

Et c'est la colonne B qui contiendra les "bonnes" valeurs ; kamiac pourra masquer la colonne A.
S'il veut aller plus loin, il pourra même sélectionner la colonne B, faire COPIER, puis (sans quitter la colonne) faire COLLAGE SPECIAL/VALEURS ; ainsi les formules disparaissent et laissent place au résultat du calcul ; il peut alors supprimer la colonne A, qui ne sert désormais à rien ...

Cordialement