SVCHOST.EXE --> Lag

[Résolu/Fermé]
Signaler
-
 Xasher -
Bonsoir,
Je voudrai desactiver/supprimer SVCHOST.EXE..
Cette application me prend 50% de mon proc... C est a dire 1,5 Gigahertz (assez lourd je trouve)
SI quelqu un pourrait me conseiller
Merci
Mike
A voir également:

42 réponses

Messages postés
2534
Date d'inscription
dimanche 13 novembre 2005
Statut
Membre
Dernière intervention
22 novembre 2014
1 538
salut

Voila une solution testée plusieurs fois et fonctionnelle

Dans un premier temps vous devez aller dans le panneau de configuration et désactiver le service de mise à jour automatique.
Ok, maintenant vous êtes tranquille , car le processus "svchost.exe" qui vous faisait rammer le processeur doit s'arèter, ou se calmer.
(A noter que ce processus system peu etre arrèter dans le gestionnaire de tâche.Mais il réapparait si vous ne désactivez pas le service de mise a jour automatique).



1. Cliquez sur "démarer" puis "exécuter"
2. Tappez "REGSVR32 WUAPI.DLL" (sans les guillemets) et presser OK
3. Quand on reçois le message "DllRegisterServer in WUAPI.DLL succeeded" message, click OK.
4. En suite exécuter les commandes suivantes dans "exécuter":

REGSVR32 WUAUENG.DLL
REGSVR32 WUAUENG1.DLL
REGSVR32 ATL.DLL
REGSVR32 WUCLTUI.DLL
REGSVR32 WUPS.DLL
REGSVR32 WUPS2.DLL
REGSVR32 WUWEB.DLL



1. Cliquez sur "démarer" puis "exécuter" et tappez " cmd "

Dans la fenetre d'invite de commande qui s'ouvre tappez:

net stop WuAuServ



2. Cliquez sur "démarer" puis "exécuter" et tappez " %windir% " cela ouvre le dossier system32

3. Recherchez le dossier "SoftwareDistribution" faire un clique droit dessus et renommez le en " SDold ".

4.Cliquez sur "démarer" puis "exécuter" et tappez " cmd "

Dans la fenetre d'invite de commande qui s'ouvre tappez:

net start WuAuServ


Et voila le problème est résolu, finis les formattage et réinstallations de XP.
85
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
1
Date d'inscription
vendredi 18 décembre 2015
Statut
Membre
Dernière intervention
18 décembre 2015

Hello!
J'ai un problème similaire sous windows 10. J'ai désactivé windows update, mais la suite des commandes REGSVR 32 semble ne pas fonctionner: ça me renvoit des messages d'erreurs:
La première commande me renvoit ça : "Le module WUAUENG.DLL a été chargé, mais le point d'entrée DIIRegisterServer est introuvable.
Vérifier que "WUAUENG.DLL" est une fichier DLL ou OCX valide, puis réessayer."
et les suivantes quelques chose du genre :echec de chargement du module; fichier introuvable.
Il n'y en a qu'une qui semble fonctionner: REGSVR32 ATL.DLL
En tout cas avec WU désactivé, il me reste ce processus
"hote de service : systeme local (15)" en lien avec svchost.exe, qui bouffe de la connexion, ( jusqu'à 0.7 Mbit/s ) et qui se relance au bout de quelques minutes si j'essaye de le fermer (fin de tâche)
J'ai essayé de désactiver au démarage tout ce qui n'est pas microsoft, mais rien n'y fait. Je farfouille un peu sur les forums mais ne trouve pas de solution...
Quelqu'un aurait-il une idée miraculeuse? S'il lui plaît ? :)
(et merci quand même pour ce tuto bien fait!)
Messages postés
114
Date d'inscription
dimanche 9 décembre 2007
Statut
Membre
Dernière intervention
24 janvier 2021

Bonjour à tous,

Merci de votre aide car là je tourne en rond.

J'ai mon portable dont l'UC tourne à 100 % avec le service Windows Update en cours d'éxécution.

Dès que j'arrête le service Windows Update l'utilisation de l'UC redevient normal entre 4 et 23 %.

J'ai donc suivi les conseil de La Loupiote et appliqué sa méthode.

Là je me suis aperçu qu'il me manquant certains fichiers DLL. Je les ai donc installés.
Puis j'ai repris la méthode qui a fonctionné de bout en bout.

Mais lorsque je remets en route le service Windows Update mon portable tourne bien pendant quelques minutes et puis d'un seul coup, l'utilisation de l'UC remonte à 100 %.

Le problème n'est pas résolu. Et si j'arrête le service Windows Update de nouveau, le taux d'utilisation redescend immédiatement.

Je n'arrive pas à me sortir de ce cercle vicieux.

Avez-vous d'autres pistes ?

Merci à tous

JPC45200
Merci loupiote! ça marche impec!
Tu fais encore de émules La loupiote... je suis passé de 100% à 4/15% ! Excellent !
Merci à toi !
Salut, ça marche toujours, merci pour ton aide !
Messages postés
10
Date d'inscription
lundi 13 avril 2009
Statut
Membre
Dernière intervention
15 avril 2009
12
j'avais le meme probleme sur vista mais j'avais un des 4 coeurs qui était a 100% et faisait ramé le pc il fallait redémarrer j'ai eu cette info et sa marche
'ai trouvé cette solution après bien des heures à chercher le pourquoi du comment.
En fait il s'agit d'un bug de Windows qui apparait généralement après une mise à jour d'un produit "Office".
Et qui provoque une corruption du dossier "software distribution"


Voila une solution testée plusieurs fois et fonctionnelle

Dans un premier temps vous devez aller dans le panneau de configuration et désactiver le service de mise à jour automatique.
Ok, maintenant vous êtes tranquille, car le processus "svchost.exe" qui vous faisait ramer le processeur doit s'arrêter, ou se calmer.
(A noter que ce processus system peu être arrêter dans le gestionnaire de tâche. Mais il réapparait si vous ne désactivez pas le service de mise à jour automatique).



1. Cliquez sur "démarrer" puis "exécuter"
2. Tapez "REGSVR32 WUAPI.DLL" (sans les guillemets) et presser OK
3. Quand on reçois le message "DllRegisterServer in WUAPI.DLL succeeded" message, click OK.
4. En suite executer les commandes suivantes dans "executer":

REGSVR32 WUAUENG.DLL
REGSVR32 WUAUENG1.DLL
REGSVR32 ATL.DLL
REGSVR32 WUCLTUI.DLL
REGSVR32 WUPS.DLL
REGSVR32 WUPS2.DLL
REGSVR32 WUWEB.DLL



1. Cliquez sur "démarrer" puis "exécuter" et tapez " cmd "

Dans la fenêtre d'invite de commande qui s'ouvre tapez:

net stop WuAuServ



2. Cliquez sur "démarrer" puis "exécuter" et tapez " %windir% " cela ouvre le dossier system32

3. Recherchez le dossier "Software Distribution" faire un clique droit dessus et renommez le en " SDold ".

4.Cliquez sur "démarrer" puis "exécuter" et tapez " cmd "

Dans la fenêtre d'invite de commande qui s'ouvre tapez:

net START WuAuServ


Et voila le problème est résolu, finis les formatage et réinstallations de XP.

P.S. Pour vos commentaires vous pouvez m'écrire à contact @ pc-secours.ch (sans les espaces avant et âpres le @)






Après avoir désactivé le service de mise à jour automatique, est ce qu'il est donc nécessaire de poursuivre à ces 4 étapes
, car le processus "svchost.exe" qui faisait ramer le processeur est déjà arrêter, et à quoi ça sert ces étapes

1. Cliquez sur "démarrer" puis "exécuter"
2. Tapez "REGSVR32 WUAPI.DLL" (sans les guillemets) et presser OK
3. Quand on reçois le message "DllRegisterServer in WUAPI.DLL succeeded" message, click OK.
4. En suite exécuter les commandes suivantes dans "exécuter": et ainsi de suite....

Super !!! Merci infiniment, tu m'as bien aidé !
+1 !
Merci bcp ca a marcher
ça marche pour moi, il s'est arrêté , mais espérant qu'il va pas se relancer à la prochaine démarrage. merci.
Messages postés
663
Date d'inscription
vendredi 23 décembre 2005
Statut
Membre
Dernière intervention
14 mars 2017
210
Salut,

Le logiciel pour connaître les fichiers qui sont chargés dans un processus s'appelle Kill Process.
Messages postés
663
Date d'inscription
vendredi 23 décembre 2005
Statut
Membre
Dernière intervention
14 mars 2017
210
Pour limiter les ressources, tu peux descendre la priorité du processus : dans le gestionnaire des tâches, tu cliques droit sur le processus tu vas dans définir la priorité et tu mets inférieur à la normal ou basse.
Messages postés
992
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
25 septembre 2007
362
C'est un problème connu lié normalement à Microsoft Update (Windows Update ne doit normalement pas le provoqué), Microsoft a publié un correctif à ce sujet, mais il s'agit plutôt d'une vulgaire rustine plutôt que d'un réel correctif.

http://www.microsoft.com/downloads/details.aspx?displaylang=fr&FamilyID=7a81b0cd-a0b9-497e-8a89-404327772e5a

Une autre solution consiste à n'utiliser que Windows Update et pas Microsoft Update (si vous possédez des produits de type Microsoft Pack Office, il vous faudra faire les mises à jours manuellement). Pour repasser à Windows Update depuis Microsoft Update : https://support.microsoft.com/en-us/help/901037/how-to-enable-and-to-disable-microsoft-update/
Bonjour

Pour ce que j'en connais, attention à ne pas supprimer arbitrairement n'importe quel SVCHOST. Derrière ce nom un peu babare, il y a une application qui s'exécute et qui peut être essentielle au pc. Je sais qu'il existe un petit programme pour identifier SVCHOST et l'application qui lui correspond. Un petit coup de google devrait permettre de le trouver.

Je me suis rendu compte chez moi avec ProcessExplorer que ça venait de wuauclt.exe (des mises à jours automatiques)

Pour résoudre le problème je me suis aidé de ça :
http://episteme.arstechnica.com/eve/forums/a/tpc/f/12009443/m/786004271831?r=540004871831
et ça :
https://support.microsoft.com/en-us/help/927891/you-receive-an-access-violation-error-and-the-system-may-appear-to-bec/

Voici les étapes que j'ai suivi :

-Arrêt du service "Mises à jour automatiques"
-Installation du correctif : WindowsXP-KB927891-v3-x86-FRA.exe
-Installation forcée du deuxième correctif : WindowsUpdateAgent30-x86.exe /wuforce
-Renommage de C:\windows\software distribution en C:\windows\software distribution.old
-Renommage C:\windows\windowsupdate.log en c:\windows\windowsupdate.log.old
-redémarrage du service "Mises à jour automatiques"
Bonjour à tous...

Pareil pour moi, svchost me pique 50% des ressources cpu (dual core oblige)

A noter que winlogon et explorer me font le même coup également...ils alternent entre eux en fait...

Comment faire???
Bonsoir,
Merci de vos reponses rapides,
SVCHOST.EXE, depuis quelques jours prends bcp de ressource.. :S , SPYBOT, AD AWARE, AVASt ont rien detecté..
JE vais essayer Kill Process.
Je voudrai savoir si je pouvais limiter les ressources a SVCHOST.
Merci
Mike
J ai effectivement 4 svchost.exe differents, je ne sais pas si c est mauvais signe mais je suppose que OUI. Mais il ont tous de different ID.
COmment savoir lesquels sont "FAUX" (s'il y en a).
Merci
Mike
Re,
Merci de ta reponse tres rapide! ;)
JE ne peux pas baisser la priorité Acces refusé :S...
Ce qui est etrange est que soudainement SVCHOST c est mis a me prendre bcp de ressource, depuis ce jour, j ai eu des "Service Occupé" et je ne peux plus me connecter a MSN, il plante lors de la connection.
Pour MSN et Service occupé ce n est pas "grave" mais c est surtout l utilisation du proc qui m embete..
Merci encore
Mike
Messages postés
83
Date d'inscription
jeudi 1 décembre 2005
Statut
Membre
Dernière intervention
10 janvier 2006
5
slt si tu supprimes ou désactives svchost.exe tu n'auras plus qu'à réparer ou tout réinstaller.
Ta lenteur ne vient pas de là, mais plutot d'un programme qui s'execute combiné à ce dernier, du genre anti-virus ou même virus tout court. by labavure
Petite question un peu Hors Sujet:
Vu que SVCHOST repose sur des DLLs, s'il y en a qui ne sont pas a base de DLLs signifie qu il est FAUX ?
J ai regarde chaque svchost, tous a partir de *.dll et de svchost.exe, mais il y en a un qui possede en plus de *.tsp ( mon ami Google m a dit qu il sert pour les script serveur) ce qui me renvoit a la question :
Serveur sur mon pc ? (eMule est peut etre consideré comme serveur...)
Merci de ta patience
Mike
emule.... le logiciel plein de serveur de policiers... ne va pas dessus un conseil.
Bonsoir,
En mode sans echec SVCHOST est presque nul...
Un programme ou virus derriere doit me ralentir, meme peut etre bot,
Mon ordinateur est peut etre un Zombie ( argo du hack...)
SI quelqu un a une idée
Merci
Mike
Messages postés
83
Date d'inscription
jeudi 1 décembre 2005
Statut
Membre
Dernière intervention
10 janvier 2006
5
Re,çà peut venir d'emule comme de l'assistance à distance,mais là je pencherai plutôt sur emule.
Controle les ressources lorsque cette dernière est inactive.
Bonne fin de soirée. labavure
Lu,
EN mode sans echec j ai demarrer les programmes 1 par 1, mon svchost est resté nul pourtant avec Emule, Skype , MSN , Yahoo..
Au reboot, retour sous Windows normal, surprise svchost.exe c est divisé en 4 et n est plus groupé, et son niveau d utilisation du processeur est quasi nul..
X est sans doute Windows et c est quelques inconvenients, mais c est pour ca qu on l'aime ;)..
Merci a tous Mike
Bonjour à tous,
depuis peu j'ai eu moi aussi soudainement un SVCHOST.EXE qui me prend toute mes ressources. Etant novice, tu pourrez m'expliquez précisément Mike comment tu as fait pour l'enlever car il je ne voit que le formatage comme solution(peut être un peu trop violente ;))
Merci d'avance
J'ai moi aussi eu ce probléme, il ma suffit de metre a jour mon anti virus et de supprimer quelque crasse pour que tous reviénne a la normal
Moi j'ai trouvé un moyen infaillible pour trouver les "bons" svchost des "mauvais" ils suffit de voir leurs "handles" (à afficher avec le menu affichage>sélectionner les colonnes dans le gestionnaire des tâches) vous pouvez supprimer ceux avec un handle de moins de 195

a- Seyhan löl
Dans mon cas j'ai résolu le problème en desactivant la mise a jour automatique de windows dans les paramètres de securité
Si le problème est résolu en désactivant la mise a jour de Windows il apparait un autre souci : impossible de mettre a jour windows avec Windows Update. Dès que je lance la mise a jour, svchost.exe utilise toutes les ressources et on assiste au defilement des petits carrés verts de la MAJ en boucle sans résultat.