[Suse] Installation impossible [PK_TMP_DIR]

[Fermé]
Signaler
-
Messages postés
30058
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
10 septembre 2021
-
Bonjour,
j'ai un portable que j'ai reçu de la région réunion, qui a malheureusement était installer sous SUZE entreprise 11 personnellement je suis un adépte de windows... et je comprend absolument rien a linux, le probléme avec se portable c'est que je que je peut rien installer, apparrement les personne qui l'on installer on du désactiver "je sais pas trop quoi" et sa m'enerve, je ne peut pas le formater car il y a un mot de passe sur le bios, et si j'y arrive j'aurai surement une amande, je voudrai régler le probléme d'installation des log .rpm il me fait a chaque fois "Une erreur systeme est interne est survenue" dans les detail c'est écrit, [PK_TMP_DIR|dir:///var/tmp/TmpDir.bb1hf4] Repository already exists. mercii pour vos futur réponse


2 réponses

Cest mal barré ! Sans mdp.... Il est cadenassé
Messages postés
30058
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
10 septembre 2021
7 167
Si je peux me permettre tu devrais prendre 15min pour lire vite fait la documentation suse. Sous linux tout s'installe via un gestionnaire de paquets (l'équivalent d'ajouter/supprimer des programmes de windows) à ceci prêt que tu n'as rien à télécharger manuellement sur des sites à la main, il le fait pour toi.
https://fr.opensuse.org/YaST/Modules/Software_Management
https://fr.opensuse.org/Zypper

Pour utiliser ce logiciel, de même que windows requiert des droits administrateur pour ce genre d'opération, il en est de même sous linux. L'administrateur s'appelle touours root sous linux. Yast, le gestionnaire de paquets de Suse (avec zypper), te demandera donc probablement ton mot de passe root. Sans lui, impossible d'aller plus loin.

Ceci dit dans ton cas, ce n'est à mon avis pas le seul problème.

Contrairement à windows, les messages d'erreur linux peuvent mener efficacement à une solution simplement en copiant collant le message d'erreur dans google.
https://www.lmgtfy.app/?q=%5BPK_TMP_DIR%7Cdir%3A%2F%2F%2Fvar%2Ftmp%2FTmpDir%5D+Repository+already+exists

On tombe notamment là-dessus, apparemment ton gestionnaire de paquets est dans un état inconsistant :
https://forums.opensuse.org/showthread.php/441719-repository-already-exists

Bonne chance