Excel :moyenne si dans cellules non contigües

Résolu/Fermé
yapluka
Messages postés
49
Date d'inscription
mardi 30 octobre 2007
Statut
Membre
Dernière intervention
18 septembre 2011
- 21 nov. 2010 à 04:56
 flavien - 10 déc. 2015 à 11:37
Bonjour,

Après quelques nombreuses recherches infructueuses sur internet voici ma question:
Comment réaliser la moyenne de cellules non contigües en ne prenant pas en compte les cellules vides ou = 0.
Lorsque je tape cette formule: =MOYENNE.SI(D4;F4;H8;K8;"<>0") Excel me répond que j'ai trop d'arguments. Comment faire?

merci pour vos suggestions
Cordialement
jean Yves

10 réponses

Mike-31
Messages postés
18013
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 août 2022
4 965
Modifié par Mike-31 le 19/01/2012 à 18:36
Salut,

Je ne vois pas l'intérêt de relancer une discussion de 2010 en statut résolu sur une solution à été déposé par Lermite que je salue et correspond tout à fait à la demande avec AVERAGEA()
sinon sans passer par des regroupages de valeurs il y a

=SOMME(D2;D5;D7;H2)/(NB.SI(D2;">"&0)+NB.SI(D5;">"&0)+NB.SI(D7;">"&0)+NB.SI(H2;">"&0))
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
3
Bonjour Mike-31 et merci. Toi seul a pu EXACTEMENT résoudre ce problème de Moyenne.si sur des cellules non contigües.
0
Excellente solution Mike-31 !
0