Problème de formule dans Excel

Résolu/Fermé
Messages postés
13
Date d'inscription
samedi 1 mai 2010
Statut
Membre
Dernière intervention
23 février 2011
-
Messages postés
13
Date d'inscription
samedi 1 mai 2010
Statut
Membre
Dernière intervention
23 février 2011
-
Bonjour,

je suis sur une formule "casse tête" sur Excel j'aurai besoin d'aide svp.

les paramètres sont les suivants:

mon produit de base coute 100 €

si la date de vente est réalisée entre le 15-juin et le 16-juin on applique 20% de remise
si la date de vente est réalisée entre le 17-juin et le 18-juin on applique 34% de remise
si la date de vente est réalisée entre le 19-juin et le 20-juin on applique 28% de remise

quelle est la formule qui me permet automatiquement d'avoir les résultats.


Merci par avance...





3 réponses

Messages postés
10197
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 janvier 2022
2 275
bonjour
une solution

Le prix est en A2, la date en B2 le resultat en C2

C2=SI(OU(B2=DATE(2010;6;15);B2=DATE(2010;6;16));A2*0,8;SI(OU(B2=DATE(2010;6;17);B2=DATE(2010;6;18));A2*0,66;SI(OU(B2=DATE(2010;6;19);B2=DATE(2010;6;20));A2*0,72)))

bon courage
Messages postés
26411
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
6 191
Bonjour
pour faciliter l'écriture de formule incluant des dates sus excel
avec pour l'exemple, la date en A1 le prix en B1:
en G1=15/6/2010
=Si(ET(A1>=$G$1;A1<=$G$1+1);B1*20%;SI(ET(A1>=$G$1+2;A1<=&G&1+3);B1*34%;SI(ET(A1>=$G$1+4;A1<=$G$1+5);B1*28%;"")))
ça devrait aller

vous pouvez aussi si les écarts de date sont plus important, mettre les dates limites dans un tableau et remplacer $G$1+x par l'adresse de la cellule correspondante.
A tirer sur la hauteur du champ

crdlmnt
PS cette formule donne le montant de la remise. Pour avoir le m^prix net, utiliser la valeur à complémentaire à 100%, bien sur.


Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
Messages postés
13
Date d'inscription
samedi 1 mai 2010
Statut
Membre
Dernière intervention
23 février 2011

MERCI BCP