Grub rescue : boot impossible

Résolu/Fermé
biduche
Messages postés
4
Date d'inscription
vendredi 10 avril 2009
Statut
Membre
Dernière intervention
24 janvier 2011
- 11 nov. 2010 à 20:07
 fredo - 14 déc. 2016 à 16:10
Bonjour,

après l'installation de ubuntu 10.10, tout a marché pendant qques jours puis impossible de démarrer ubuntu.
j'ai le message suivant :
error: unknown filesystem
grub rescue>

impossible de booter sur le cd pour réinstaller.
en tapant ls, j'ai
(hd0) (hd0,msdos5) (hd0,msdos1)

Que se passe-t-il? pouvez-vous m'aider, svp?

Merci d'avance



7 réponses

bwazou
Messages postés
78
Date d'inscription
mardi 30 octobre 2007
Statut
Membre
Dernière intervention
12 août 2014
33
Modifié le 31 janv. 2019 à 16:23
J'ai eu un problème à peu près similaire, sauf que je n'avais aucun message d'erreur dans la console grub. Le problème est arrivé après une mise à jour et au redémarrage je me retrouvais dans la console grub.

J'ai tenté un boot sur un alternate cd comme préconisé par EminoMeneko, mais ça n'a rien donné. Cette opération réinstalle grub sans récréer le fichier grub.cfg

Voici comment je m'en suis sorti à partir de la console grub.

ls me donnait
(hd0) (hd0,msdos1) 

et
set
prefix=(hd0,msdos1)/boot/grub 
root=(hd0,msdos1) 


Pour réparer j'ai fait:
ls (hd0,msdos1)/boot

pour noter les dernières version de vmlinuz et initrd
vmlinuz-2.6.28-35-generic et initrd.img-2.6.28-35-generic

Ensuite
insmod linux

linux /boot/vmlinuz-2.6.28-35-generic root=/dev/sda1 quiet

initrd /boot/initrd.img-2.6.28-35-generic

boot


Et la miracle ubuntu à démarré
Pour finir, dans une fenêtre shell
sudo update-grub

sudo grub-install /dev/sda1


Info trouvée ici http://forum.ubuntu-fr.org/viewtopic.php?id=358656

Ubuntu 10.1 / XP Pro SP3
Firefox 4
13
Merci pour le procédure
0
alélouilla
0
magic-brtezel
Messages postés
3
Date d'inscription
vendredi 16 avril 2004
Statut
Membre
Dernière intervention
8 novembre 2014

9 juin 2014 à 19:51
Merci pour ton aide ! j'ai rencontré le même problème. Cependant, en suivant tes indications, j'ai obtenu une erreur lors de la dernière étape (grub-install, quand on a réussi à booter une 1e fois).
Ce qui a marché chez moi est de réinstaller le bootloader depuis un Live CD de linux (vu http://ubuntuforums.org/showthread.php?t=1014708 , qui était indiqué dans une des réponses du lien que tu as cité comme source)
0
bwazou
Messages postés
78
Date d'inscription
mardi 30 octobre 2007
Statut
Membre
Dernière intervention
12 août 2014
33
12 août 2014 à 14:04
Effectivement j'ai aussi eu une erreur, aujourd'hui, sur la dernière ligne étape sudo grub-install /dev/sda1, mais ça a quand même redémarré normalement. C'est vraiment soulant cette histoire de perdre la config grub lors d'une mise à jour.

Je suis en 12.04.5 LTS car je peux pas passer au dessus à cause du processeur trop ancien.
0
la commande Is n'est pas reconnu. Que faire? merci d'avance.
0