Excel/date sur deux cellules

Résolu/Fermé
benji71 Messages postés 738 Date d'inscription samedi 22 mars 2008 Statut Membre Dernière intervention 4 janvier 2015 - 6 nov. 2010 à 15:35
Le Pingou Messages postés 11438 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 5 février 2023 - 7 nov. 2010 à 21:22
Bonjour à tous et ttes,
je fais de nouveau appel à vos compétences et savoirs pour m'aider à résoudre deux problèmes qu'il m'est difficile de mettre en mots c'est pourquoi je joins le fichier;

http://www.cijoint.fr/cjlink.php?file=cj201011/cijU1gtec2.xls

En deux mots voici mon premier problème;
j'ai une cellule ou j'ai une date j1.

Patrice33740 m'avait proposer une formule pour faire en sorte que les dates d'un mois aillent du premier jour au dernier jour de ce même mois
(=SI(MOIS($A1)=MOIS($A1+COLONNE()-1);$A1+COLONNE()-1;"")

je souhaite appliquer cette formule mais le hic c'est que si je place cette formule en h2 et que je tire la fomule cela bug..la raison doit -être selon moi que j'ai deux cellules pour mettre le jour. j'ai besoin de deux cellules pour indiquer les présences du matin et celle de l'après-midi.

avez-vous une idée pour comment je pourrais faire pour que la formule proposé par patrice focntionne ?

ma seconde question est la suivante ;
comme sur l'exmple j'ai placé une date de sortie à manöelle..j'aimerais que les cellules à partir de la date de sortie jusqu'au dernier jour du mois puisse être hachuré ...pour moi je devrais passer par la mfc...le problème est à nouveau mes deux cellules ds lesquelles est repris le jour du mois ds ce cas c'est le h3:i3.

auriez-vous u ne piste de solution pour moi ?

merci de vos précieux conseils set avis.

bien à vous.

berni et ses petites affaires...


A voir également:

5 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 307
Modifié par Vaucluse le 6/11/2010 à 17:45
Re re Benji!

Pour la première question, tu aurais du retourner sur ton fil correspondant, Gbinform t'avait donné la solution.
En H2 tu gardes J1+1 et ensuite en J2, la formule à tirer à droite

=SI(H2="";"";SI(MOIS(H2+1)<>MOIS($J$1);"";H2+1))

Ça devrait marcher, à priori d'après ce que j'ai testé
Pour la 2° question, je regarde
Crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 307
6 nov. 2010 à 17:53
on continue avec la MFC
elle devrait être suffisante sur les dernières colonnes, soit:BL à BQ
Tu saisis le champ BL2:BQ3
MFC tu rentres la formules:
=ET(BL$2="";BM$2="")
tu formates
attention aux blocages.
... et dans la mesure du possible essaie d'éviter les cellules fusionnées, c'est un vrai casse tête ensuite dans les formules.

Bien cordialement. A la prochaine :-)
0
benji71 Messages postés 738 Date d'inscription samedi 22 mars 2008 Statut Membre Dernière intervention 4 janvier 2015 25
6 nov. 2010 à 20:35
Bonsoir vaucluse,

comme tjs fidèle au poste...sois en remercié...

mon premier problème est résolu mais pas le second...je ne comprends pas la solution de la mfc

"elle devrait être suffisante sur les dernières colonnes, soit:BL à BQ
Tu saisis le champ BL2:BQ3
MFC tu rentres la formules:
=ET(BL$2="";BM$2="")
tu formates "


car pour moi pour hachuré les cellules p20:bo20. qui sont celles qui suivent la date de sortie de maneëlle...je comprends pas pq aller chercher BL2:BQ3 ?


je pensais pluôt partir du jour indiqué dans la ligne 3 et mettre la date du jour en relation avec la date de sortie mais peut-être que je me trompe ou que cel qn'est pas possible..?


merci de ton aide et conseil..

Bien cordialement..

berni et ses tites affaires...
0
Le Pingou Messages postés 11438 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 5 février 2023 1 332
7 nov. 2010 à 00:04
Bonsoir,
La solution du second cas passe par la création d'une ligne intermédiaire (ligne 32) car il est impossible de travailler correctement avec des cellules fusionnées ....!
La solution à découvrir : https://www.cjoint.com/?0lhadpffIlg
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 307
Modifié par Vaucluse le 9/11/2010 à 10:24
Bonjour tous

Je n'avais pas compris la question comme ça,mais ça va s'arranger.
Mon ami Le Pingou (salut) a bien raison, mais il y a toujours moyen de ruser avec excel

Sélectionner le champ H6:BQ30
pour la MFC la formule est:

=ET($F6>0;COLONNE()>=($F6-$J$1+1)*2+8)

Attention au blocage, et bien sur valable tant que les colonnes restent à leur place, sinon ajuster avec le 8
Voila ce que ça donne en rouge dans le fichier ci joint:
http://www.cijoint.fr/cjlink.php?file=cj201011/cijGMy8L9d.xls

Bien cordialement et bon dimanche
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
0
Le Pingou Messages postés 11438 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 5 février 2023 1 332
7 nov. 2010 à 21:22
Bonsoir Vaucluse,
Merci pour cette superbe combinaison que je ne connaissais pas.
Amicales salutations.
Le Pingou
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
benji71 Messages postés 738 Date d'inscription samedi 22 mars 2008 Statut Membre Dernière intervention 4 janvier 2015 25
7 nov. 2010 à 08:55
Bonjour le pingou et vaucluse,

comme d'habitude fidèle au poste...soyez en remercier....un merci est parfois peu de chose mais je vous l'adresse de manière sincère...vous êtes souvent prêt à rendre service et cela peu sembler peut de chose mais pour des type comme moi c'est enorme...encore un tt grand MERCI.

cordialement...

berni et ses tites affaires...
0