Connexion graphique en ssh

Résolu/Fermé
Dawid
Messages postés
432
Date d'inscription
vendredi 21 janvier 2005
Statut
Membre
Dernière intervention
24 décembre 2011
- 10 déc. 2005 à 16:16
Dawid
Messages postés
432
Date d'inscription
vendredi 21 janvier 2005
Statut
Membre
Dernière intervention
24 décembre 2011
- 12 déc. 2005 à 09:50
Voici mon problème avec ssh :

Quand je me connecte en ssh depuis une mandriva sur une mandriva, je peux lancer mes applications graphiques.

Par contre, quand je me connecte depuis ma mandriva sur une Debian Sarge (ou une Suse 9.2), je ne peux lancer que des applications en lignes de commandes.

Que faut-il faire pour que les applications que j'exécute à distance puissent s'afficher sur mon serveur X ?

5 réponses

jipicy
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 900
10 déc. 2005 à 16:26
Salut,

Éditer le fichier "/etc/ssh/sshd_config" et mettre la directive "X11Forwarding" à "yes"
Relancer le serveur :
/etc/init.d/ssh restart
Avoir une clé d'authentification valide !!!
;-))
0
kmf31
Messages postés
1564
Date d'inscription
mercredi 30 mars 2005
Statut
Contributeur
Dernière intervention
22 juin 2007
496
10 déc. 2005 à 16:29
Il faut mettre la directive:
ForwardX11 yes

dans le ficher sshd_config (probablement dans le repertoire /etc/ssh/...) du serveur ssh (la machine Suse ou Debian dans ton cas) et apres redemarrer le service sshd sur cette machine.

Apres on peut aussi ajouter les deux lignes:
Host *
        ForwardX11 yes

dans le fichier ~/.ssh/config dans son repertoire home utilisateur (du client et/ou seurveur ?). Je ne suis pas sur si ca suffit si le fichier sshd_config du serveur n'a pas la bonne directive. Peut-etre oui, il faut essayer. Sinon il faut modifer sshd_config sur le serveur comme indique.
0
mamiemando
Messages postés
31174
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 juin 2022
7 367
11 déc. 2005 à 14:19
Il faut d'une par que le X11 fowarding soit activé comme on vient de te le dire, mais aussi passer l'option -X à ssh (eventuellement -C pour compresser le flux) : exemple :
ssh -XC 192.168.0.1

Pour plus d'infos :
man ssh

Bonne chance
0
kmf31
Messages postés
1564
Date d'inscription
mercredi 30 mars 2005
Statut
Contributeur
Dernière intervention
22 juin 2007
496
11 déc. 2005 à 21:36
C'est genial l'option "-C", je ne la connaissait pas. Je viens d'essayer et il semble ca marche nettement mieux pour des applications graphiques (avec une connexion ADSL).
0
Dawid
Messages postés
432
Date d'inscription
vendredi 21 janvier 2005
Statut
Membre
Dernière intervention
24 décembre 2011
62
11 déc. 2005 à 19:23
Merci pour tout.

Je vais essayer tout ça et je vous dis si ça a marché.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Dawid
Messages postés
432
Date d'inscription
vendredi 21 janvier 2005
Statut
Membre
Dernière intervention
24 décembre 2011
62
12 déc. 2005 à 09:50
Merci pour tout !

Ça marche très bien (j'ai enfin eu le temps de tester).
0