Problème ouverture de swf dans une page html

Résolu/Fermé
ANGEL - 29 oct. 2010 à 16:25
 ANGEL - 29 oct. 2010 à 21:58
Bonjour,
je suis entrain de faire une page web en html et j'ai intégrer dedans une animation swf (via insert- media- files- swf de dreamweaver cs5)

le dossier est sur le bureau et contient l'animation swf et la page html

quand exécute pour voir le résultat sur firefox ou même ie j'ai toujours l'icône d'adobe GET ADOBE FLASH PLAYER alors que j'ai déja adobe flash player et la dernière version


Merci pour votre aide

6 réponses

osso045
Messages postés
178
Date d'inscription
dimanche 14 mars 2010
Statut
Membre
Dernière intervention
30 mai 2011

29 oct. 2010 à 17:40
en local je crois ça ne marche pas bien, il faut héberger la page pour vois ce que ça donne
cord.
0
MastercroW
Messages postés
1095
Date d'inscription
dimanche 3 octobre 2010
Statut
Membre
Dernière intervention
31 mai 2019
163
29 oct. 2010 à 17:44
Bonsoir, déjà pour commencé as-tu la bonne version de FLASH ?
Je te conseil d'aller faire un tour sur : https://get.adobe.com/flashplayer/?loc=fr
Ensuite, tu as la "chance" d'avoir DreamWeaver cs5, donc il suffit d'insérer l'animation en 2 clics :
--> Insertion : Média puis 'SWF'

Voilà, sinon peux être un problème de ton localhost qui ne marche pas très bien comme nous le dit cord.
0
oui j'ai cs5 et la dernière version de flash player
mais est ce que je dois installer un serveur en local pour que ca ?
0
MastercroW
Messages postés
1095
Date d'inscription
dimanche 3 octobre 2010
Statut
Membre
Dernière intervention
31 mai 2019
163
29 oct. 2010 à 18:52
Non, tu n'es pas obligé, après tout dépend de ton FLASH (si ton swf est PHP/SQL).
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
bg62
Messages postés
23260
Date d'inscription
samedi 22 octobre 2005
Statut
Modérateur
Dernière intervention
13 mai 2022
2 318
29 oct. 2010 à 19:00
si ton swf est PHP/SQL

??? explications ???
essaie ceci (ça fonctionne ,c'est sur, si tu as des problèmes, mets ton code)
<p style="text-align: center;"><object width="600" height="200" codebase="http://fpdownload2.macromedia.com/get/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000">
<param value="images/MONFICHIER.swf" name="movie" />
<param value="best" name="quality" />
<param value="true" name="menu" />
<param value="always" name="allowScriptAccess" /><embed width="600" height="200" allowscriptaccess="always" pluginspage="https://get.adobe.com/flashplayer/" type="application/x-shockwave-flash" menu="true" quality="best" src="images/MONFICHIER.swf"></embed></object></p>

Là le fichier est dans un dossier "images", tu peux en changer le lien ...
attention aussi à bien mettre SA largeur et SA hauteur dans le code
:-)
0
Bonsoir,
c'est bon ca marche le problème venez du fait que la page html ,le fichier swf et le .js ne sont pas dans le même dossier
Merci à vous tous
0