1er et dernier jour du mois automatique/excel [Fermé]

Signaler
-
Messages postés
25298
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2020
-
Bonjour,


J'ai un tableau excel avec des mois... janvier, fevrier...
Et j'ai besoin de mettre en automatique le 1er jour du mois et le dernier.
Exel : A1 : Janvier
B1 : 01/01/2010
C1 : 31/01/2010

Merci pour votre aide

2 réponses

Messages postés
16209
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2020
3 031
bonjour,

dans un endroit de la feuille inutilisé tu marques le n° du mois et l'année
par ex dans K1 tu écris 1 'pour janvier et L1 2010 pour l'année

dans A1=TEXTE(1&"/"&K1;"mmmm") te renvoie "janvier"
dans B1=DATE(L1;K1;1)
dans C1==DATE(L1;K1;FIN.MOIS(K1;0))

Fin.mois est activé par l'utilitaire d'analyse (outils-macrocomplémentaire)

ainsi, ta feuille marche en perpétuel en changeant K1 ET/ou L1


3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60456 internautes nous ont dit merci ce mois-ci

Messages postés
25298
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2020
5 476
Bonjour
si janvier est en 1:
En B1:
=DATEVAL(1&"/"&LIGNE(A1)&"/2010")
En C1
=DATEVAL(1&"/"&MOIS(B1)+1&"/2010")-1
à tirer jusqu'en décembre
note:
sur C1,ne marche pas en décembre
pour décembre, il faut compliquer un peu c'est à dire:
=SI(MOIS(B1)=12;B1+30;=DATEVAL(1&"/"&MOIS(B1)+1&"/2010")-1

crdlmnt