Oracle: L'installation demarre mais ...

Fermé
Gast30 Messages postés 16 Date d'inscription mercredi 16 novembre 2005 Statut Membre Dernière intervention 3 février 2006 - 22 nov. 2005 à 18:15
 Yoblys - 17 avril 2008 à 15:49
Salut,
oracle me fais du mal. L'installation demarre mais reste à 0% pour plusieurs heures. Pas de fautes. Pas de signal de mécontentements mais rien n'avance! N'est pas déprimant?
Qui peux bien m'aider?
A+

12 réponses

mamiemando Messages postés 32123 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 février 2023 7 542
22 nov. 2005 à 20:25
Sans message d'erreur on ne peut pas t'aider. Vérifie que ta connection réseau marche bien, que le paquet que tu télécharges est accessible.

Sinon essaye de télécharger des sources et de les compiler à la main.
0
Gast30 Messages postés 16 Date d'inscription mercredi 16 novembre 2005 Statut Membre Dernière intervention 3 février 2006
23 nov. 2005 à 10:10
J'ai les cds d'installation originaux que j'ai copier sur le disque et c'est de là que je demarre l'installation. La pré-configuration est aussi bonne. En tout cas c'est que je crois.
Ya t-il incompatibilités entre suse 10.0 et oracle 9.2 ?
0
mamiemando Messages postés 32123 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 février 2023 7 542
23 nov. 2005 à 18:05
Mais tu es sûr que tu as bien le paquetage oracle ? Sinon peut être qu'en le téléchargeant... Essaye de lancer l'installe en mode texte avec apt-get pour voir les messages d'erreur.
0
Gast30 Messages postés 16 Date d'inscription mercredi 16 novembre 2005 Statut Membre Dernière intervention 3 février 2006
24 nov. 2005 à 11:08
apt-get lance command not found. Quel packet dois-je installer?
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
mamiemando Messages postés 32123 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 février 2023 7 542
24 nov. 2005 à 16:16
Tu es en root ?
http://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.2-i386/RPMS.suser-rbos/
(google is life)

Enfin moi j'ai dit apt-get parce qu'il me semblait que c'était la manière classique d'installer des paquets en mode texte.

Bonne chance
0
Gast30 Messages postés 16 Date d'inscription mercredi 16 novembre 2005 Statut Membre Dernière intervention 3 février 2006
24 nov. 2005 à 17:41
Pour installer oracle on ne doit pas être lancer l'installation avec root. Le veritable pb c'est que je ne recoit pas de fautes. J'ai eu à reinstaller suse, j2sk1.4.2 actualiser le path...
Les cds d'installations sont de la maison oracle. C'est curieux et dois absolument reussir si c'est possible quela combinaison 9i et suse 10 fonctionne
0
mamiemando Messages postés 32123 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 février 2023 7 542
24 nov. 2005 à 20:00
Pour installer oracle on ne doit pas être lancer l'installation avec root.

Hein ? Pourquoi donc ? Il est bien root le type là :
http://www.linux-france.org/article/serveur/sgbd/oracle/install_suse/suse7.2-ora.html
0
Gast30 Messages postés 16 Date d'inscription mercredi 16 novembre 2005 Statut Membre Dernière intervention 3 février 2006
25 nov. 2005 à 10:31
on a tout simplement besoin d'une console root parce qu'il ya des scripts que l'on pourrait executer lors de l'installation. Si tu essaies de demarrer runinstaller en tant que root, il te jette directement un message d'erreur.
0
mamiemando Messages postés 32123 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 7 février 2023 7 542
26 nov. 2005 à 01:14
Désolé là ca dépasse mes compétences, à part chrecher des liens sur google je ne vois pas ce que je pourrais faire...
0
J'ai exactement le meme probleme que toi.
Ma config est identique à la tienne.

C'est curieux, il bloque en essayant d'installer JRE ( qui est déjà installé sur la bécanne puisque l'UNiversal Installer a marché !!!!!)

en fait , voila une solution que je vai tester ce soir :

aller dans la directory d'install ; genre /u01/xyz/oracle/9.X
faire un rm JRE
faire un ln -s /xyz/xyz/Javasun1.65.55 JRE
(tu remplaces le repertoire JRE qu'oracle a créé par un lien sur le JRE de ton serveur)

tu vas dans la directory bin de ton JRE(xyz/JRE/bin) et tu cré le lien suivant : ln -s java jre

tu vas dans xyz/JRE/bin/i386 et tu fais pareil : ln -s java jre.

reessaye !!
Dis moi si ca marche !!

manu
0
Gast30 Messages postés 16 Date d'inscription mercredi 16 novembre 2005 Statut Membre Dernière intervention 3 février 2006
2 déc. 2005 à 12:38
J'ai reinstaller le system et maintenant c'est fatal. Enfin je crois.
Quand je demarre l'installation il me lance un tas de message du genre Font not Found et ensuite une exception in thread main
Vraiment bizzare tout cela. Je n'y comprend plus rien.
0
Gast30 Messages postés 16 Date d'inscription mercredi 16 novembre 2005 Statut Membre Dernière intervention 3 février 2006
2 déc. 2005 à 14:03
Voila l'erreur qui me casse les pieds. Qui peut m'aider?

Initializing Java Virtual Machine from /tmp/OraInstall2005-12-02_01-57-12PM/jre/bin/java. Please wait...
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
Font specified in font.properties not found [--symbol-medium-r-normal--*-%d-*-*-p-*-adobe-fontspecific]
View passed to RootItemDataSource does not contain data in TopicTree format.
sun.io.MalformedInputException
at sun.io.ByteToCharUTF8.convert(ByteToCharUTF8.java:85)
at java.io.InputStreamReader.convertInto(InputStreamReader.java:132)
at java.io.InputStreamReader.fill(InputStreamReader.java:181)
at java.io.InputStreamReader.read(InputStreamReader.java:244)
at java.io.BufferedReader.fill(BufferedReader.java:134)
at java.io.BufferedReader.read(BufferedReader.java:152)
at oracle.help.engine.HHCEngine$HHCReader.read(Unknown Source)
at java.io.StreamTokenizer.read(StreamTokenizer.java:467)
at java.io.StreamTokenizer.nextToken(StreamTokenizer.java:511)
at oracle.help.engine.HHCEngine.readToken(Unknown Source)
at oracle.help.engine.HHCEngine.createDataObject(Unknown Source)
at oracle.help.engine.HHCEngine.createDataObject(Unknown Source)
at oracle.help.common.View.getViewData(Unknown Source)
at oracle.help.navigator.tocNavigator.RootItemDataSource._getTopicTree(Unknown Source)
at oracle.help.navigator.tocNavigator.RootItemDataSource._createNodeInfos(Unknown Source)
at oracle.help.navigator.tocNavigator.RootItemDataSource.addTOCView(Unknown Source)
at oracle.help.navigator.tocNavigator.TOCTree.addTOCView(Unknown Source)
at oracle.help.navigator.tocNavigator.TOCNavigator.addView(Unknown Source)
at oracle.help.Help._createNavigatorForView(Unknown Source)
at oracle.help.Help._createNavigatorsForBook(Unknown Source)
at oracle.help.Help.addBook(Unknown Source)
at oracle.sysman.oii.oiix.OiixHelp.addInstHelp(OiixHelp.java:303)
at oracle.sysman.oii.oiic.OiicInstaller.init(OiicInstaller.java:310)
at oracle.sysman.oii.oiic.OiicInstaller.main(OiicInstaller.java:636)
View passed to KeywordDataSource does not contain data in TopicTree format.
sun.io.MalformedInputException
at sun.io.ByteToCharUTF8.convert(ByteToCharUTF8.java:147)
at java.io.InputStreamReader.convertInto(InputStreamReader.java:132)
at java.io.InputStreamReader.fill(InputStreamReader.java:181)
at java.io.InputStreamReader.read(InputStreamReader.java:244)
at java.io.BufferedReader.fill(BufferedReader.java:134)
at java.io.BufferedReader.read(BufferedReader.java:152)
at oracle.help.engine.HHCEngine$HHCReader.read(Unknown Source)
at java.io.StreamTokenizer.read(StreamTokenizer.java:467)
at java.io.StreamTokenizer.nextToken(StreamTokenizer.java:511)
at oracle.help.engine.HHCEngine.readToken(Unknown Source)
at oracle.help.engine.HHCEngine.createDataObject(Unknown Source)
at oracle.help.engine.HHCEngine.createDataObject(Unknown Source)
at oracle.help.engine.HHKEngine.createDataObject(Unknown Source)
at oracle.help.common.View.getViewData(Unknown Source)
at oracle.help.navigator.keywordNavigator.KeywordDataSource._getTopicTree(Unknown Source)
at oracle.help.navigator.keywordNavigator.KeywordDataSource._addViewItems(Unknown Source)
at oracle.help.navigator.keywordNavigator.KeywordDataSource.access$0(Unknown Source)
at oracle.help.navigator.keywordNavigator.KeywordDataSource$KeywordMergeTask.runTask(Unknown Source)
at oracle.ewt.thread.TaskScheduler.runTask(Unknown Source)
at oracle.ewt.thread.TaskScheduler.processTask(Unknown Source)
at oracle.ewt.thread.TaskScheduler$TaskQueue.run(Unknown Source)
at oracle.ewt.timer.Timer.doRun(Unknown Source)
at oracle.ewt.timer.Timer.run(Unknown Source)
at java.lang.Thread.run(Thread.java:479)
0
Le post est un peu vieux mais je vais y répondre quand même pour les prochains.

J'ai eu le même problème pour MalformedInputException et les fonts et je viens de le résoudre :
Installe une nouvelle jdk (j'ai pris la jdk 1.4.2)
trouve ton oraparam.ini (chez moi il est dans "oracleinstall"/install/linux/oraparam.ini
dans oraparam.ini : JRE_LOCATION=/usr/java/j2sdk1.4.2_17/ (là où t'as installé ta jdk)

et c'est tout !
0