Formule sous excel

Résolu/Fermé
mamtao - 28 sept. 2010 à 19:28
Gord21 Messages postés 918 Date d'inscription samedi 21 novembre 2009 Statut Membre Dernière intervention 20 mars 2013 - 29 sept. 2010 à 12:18
Bonjour,
Est ce que quelqu'un pourrait m'aider à écrire cette formule sous excel?

" Si un nombre multiplié par 0,50%, divisé par un Autre nombre,
le Résultat est entre 60 et 90, alors on prend le résultat,
si ce Résultat est inférieur ou égal à 60, alors on prend 60 multiplié par l'Autre nombre,
si ce Résultat est supérieur ou égal à 90, alors on prend 90 multiplié par l'Autre nombre"
Merci de votre aide.


2 réponses

Gord21 Messages postés 918 Date d'inscription samedi 21 novembre 2009 Statut Membre Dernière intervention 20 mars 2013 287
28 sept. 2010 à 23:05
Bonsoir,
Si ton nombre est en B1 et ton autre nombre en B2 :
=SI(B1/(2*B2)<=60;60*B2;SI(B1/(2*B2)>=90;90*B2;B1*(2*B2)))

@+
0
Un grand merci Gord21.
c'est génial et franchement tu m'enlèves une épine du pied, ça fonctionne parfaitement...
0
Gord21 Messages postés 918 Date d'inscription samedi 21 novembre 2009 Statut Membre Dernière intervention 20 mars 2013 287
29 sept. 2010 à 12:18
Bonjour,
J'avais un doute sur le 0,50% : j'ai divisé par 2 mais je ne sais pas si c'est ce que tu attendais (50% de la valeur = 0,50 * la valeur différent de 0,50% de la valeur).
0