Pilote nvidia sur Debian Squeeze

Fermé
kiki - 27 août 2010 à 16:14
mamiemando Messages postés 33173 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 10 juillet 2024 - 28 août 2010 à 13:19
Bonjour,

J'ai une vielle machine avec une carte nvidia geforce 4 MX4000.

Que je viens de passer a squeeze (résintall suite à une migration qui a foiré à cause du nvidia je crois), mais la dernière version du pilote ne supporte plus les geforce 4.

J'ai épiphany qui est suppert lent et qui plante : une plaie ! Alors je sais pas si c'est à cause du moteur webkit ou parce que j'ai plus de de 3D. Quand je scrolle ça prend 80% du proc, ca plante-ferme quand je clique sur le bouton arrière, ca bloque même quand je veux télécharger le pilote nvidia ! C'est invivable !

Comment avez-vous fait pour installer un pilote nvidia ancienne mouture avec squeeze : dépot supplémentaire, install manuelle du driver 100.x, etc ?

Cordialement,
A voir également:

3 réponses

mamiemando Messages postés 33173 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 10 juillet 2024 7 761
27 août 2010 à 16:50
Via module-assistant tu dois avoir des versions nvidia-legacy :

aptitude update
aptitude safe-upgrade
aptitude install module-assistant


Ensuite au choix :

m-a a-i nvidia-kernel-legacy-173xx-source
m-a a-i nvidia-kernel-legacy-71xx-source
m-a a-i nvidia-kernel-legacy-96xx-source
m-a a-i nvidia-kernel-source 


Il ne reste plus qu'à installer le .deb ainsi généré :

dpkg -i /usr/src/nvidia*deb


Bonne chance
mamiemando Messages postés 33173 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 10 juillet 2024 7 761
Modifié par mamiemando le 28/08/2010 à 13:20
J'ai essayé : ya pas de nvidia legacy en 96xx ou 71xx, il n'y a que 173xx.
Donc là si on a une carte + ancienne que la FX (geforce 5) c'est cuit.


Voici mon /etc/apt/sources.list

deb http://ftp.fr.debian.org/debian/ testing main contrib non-free  
deb https://www.debian.org/security/ testing/updates main contrib non-free  
deb https://www.debian-multimedia.org/ testing main contrib non-free  

#deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free  
#deb-src https://www.debian.org/security/ testing/updates main contrib non-free  
#deb-src https://www.debian-multimedia.org/ testing main contrib non-free  

## Dépôts Sid  
# priorités spécifiées dans /etc/apt/preferences   
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free  
#deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free


(tu noteras que les dépôts deb-src sont commentés).

... et mon /etc/apt/preferences (qu'il te faudra créer) :

Package: *  
Pin: release o=Debian,a=testing  
Pin-priority: 990  

Package: *  
Pin: release o=Debian,a=unstable  
Pin-priority: 90


Ensuite fais une mise à jour :

aptitude update  
aptitude safe-upgrade  
m-a update


gcc-4.3 : je le sens pas trop ce coup là...

Si si c'est normal. Tu peux vérifier le compilateur qui a été utilisé pour préparer ton noyau avec la commande :

cat /proc/version


Pour l'installer au choix :

m-a prepare  
aptitude install gcc-4.3


Comme c'est parti je crois que je vais devoir remplacer ma vielle bécane, snif ! Ou alors trouver une carte 6600 ou + en AGP d'occase... Ca va pas être facile...

Meuh non :) Si moi je peux construire les fameux modules legacy, ça doit être aussi possible chez toi :-)
J'ai essayé : ya pas de nvidia legacy en 96xx ou 71xx, il n'y a que 173xx.
Donc là si on a une carte + ancienne que la FX (geforce 5) c'est cuit.

J'ai tenté avec le drivers nvidia 9643 :
Il réclame les sources du kernel qui installent gcc4.4 et l'installateur nvidia réclame gcc-4.3 : je le sents pas trop ce coup là...

Comme c'est partis je crois que je vais devoir remplacer ma vielle bécane, snif ! Ou alors trouver une carte 6600 ou + en AGP d'occase... Ca va pas être facile...