Calcul à partir d'un calendrier EXCEL 2007

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
jeudi 26 août 2010
Statut
Membre
Dernière intervention
27 août 2010
-
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
-
Bonjour,

Je travail pour une chaîne hôteliere et nous avons des prix variables par période pour une chambre x

Exemple:
01/01/11 - 12/02/11 100€
13/02/11 - 28/02/11 110€
01/03/11 - 31/03/11 105€

A ce prix s'ajoute une reduction sur certaines périodes, les reductions se font sur d'autres périodes qui parfois chevauchent celles des prix

Exemple:
01/01/11 - 15/02/11 -5%
16/02/11 - 27/02/11 0%
28/02/11 - 31/03/11 -10%

Ainsi je dois casser mes periodes manuellement et calculer au cas par cas, exemple:

01/01/11 - 12/02/11 100€ -5%
13/02/11 - 15/02/11 110€ -5%
16/02/11 - 27/02/11 110€ 0%
ETC...

Je cherche donc un moyen de calculer mon prix final avec les périodes cassées ou au mieux un système de liste déroulante où en rentrant la période, le prix se calculerai directement

Je pensais à un système de recherche V ou quelque chose du genre avec une liste déroulante (système des sites internet d'agence de voyage)...

Autre solution, une methode de regroupement automatique des periodes (si le prix diffère sur la même période de réduction alors la date est cassée...)


Je prends toutes les idées qui viennent et je répondrai à vos questions si mon problème ne vous parait pas assez bien présenté...


Merci d'avance et bonne journée à tous ;)



4 réponses

Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
884
Salut le forum

Bienvenue Hervis comme nouveau membres.

En Colonne A tes dates de début de période
En Colonne B tes dates de fin de période
En Colonne C tes tarifs
En Colonne D tes pourcentage de réduction

Tableau de A1 à Dx, date de recherche en F10 (Dx à adapter)

Montant :
=RECHERCHEV(F10;$A$1:$D$x;3;1)

Rabais :
=RECHERCHEV(F10;$A$1:$D$x;4;1)

Montant et Rabais :
=RECHERCHEV(F10;$A$1:$D$x;3;1)*(1+RECHERCHEV(F10;$A$1:$D$x;4;1))


Mytå

Merci de donner suite à votre question, nous ne sommes pas des robots...
Versions installées [MsProject 2003(FR), Excel 2003-2007(FR)]
Messages postés
3
Date d'inscription
jeudi 26 août 2010
Statut
Membre
Dernière intervention
27 août 2010

ok c'est un peu l'idée que j'avais, mais je dois préparer les périodes donc...

Sinon je cherche un systéme de liste déroulante pour calculer sur une période de temps...

Par exemple une liste pr les jours/mois/année de départ et une autre pr celles d'arrivée

Après je fais les calculs et en selectionant la périodes ça me calcule le prix des jours en questions en faisant un total

En gros un système de reservation personel pour que sans le faire manuellement, je puisse connaitre le prix d'un sejour sur une période donnée

Merci encore !
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 707
Bonjour,

Ci-joint un exemple qui répond peut-être au besoin :
- une feuille Location : saisir les dates d'arrivée et de départ (limité à 1 an)
résultat sur cette feuille : différentes périodes et tarifs
- une feuille Tarif pour saisir les périodes correspondantes (limité à 100 périodes)
- une feuille Réduction (aussi limité à 100 périodes)
- une feuille Calcul
Les feuilles sont protégées (sans mot de passe)

Fichier Prix Chambre :
http://www.cijoint.fr/cjlink.php?file=cj201008/cijKUYTJs0.xls

Cordialement
Patrice
Messages postés
3
Date d'inscription
jeudi 26 août 2010
Statut
Membre
Dernière intervention
27 août 2010

Genial merci beaucoup,

Effectivement il me manque encore de sacrés formules à apprendre...Excel est un outil vraiment efficace quand on sait s'en servir!



Merci beaucoup et bonne continuation!

Problème résolu!
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 707
De rien, avec plaisir