Excel fonction RECHERCHEV avec 2 résultats [Résolu/Fermé]

Signaler
-
 RonanM35 -
Bonjour,

Je travaille actuellement sur un dossier comptable sur Excel. Ce dossier comprend l'acquisition d'immobilisations. Pour les ressortir automatiquement dans le Bilan, j'ai utilisé les numéros du Plan Comptable Général (PCG).

Par exemple le tableau de saisie des immos se présente ainsi :
Nom Immo / Prix TTC / TVA / Prix HT / Amortissement / Numéro de PCG

En me servant du numéro de PCG je peux ressortir à l'aide d'une fonction RECHERCHEV le prix HT dans le bilan, et ce de manière automatique (si je change ou rajoute une ligne en modifiant le numéro de PCG, ça modifie mon bilan automatiquement).

Mon bilan se présente ainsi :

N° PCG Prix HT

215 000
215 400
218 200
...

En effectuant la RECHERCHEV dans la colonne Prix HT, et en basant la recherche sur le N° PCG, mon bilan se présente automatiquement de la bonne façon.

Sauf que je viens de m'apercevoir que cela ne fonctionne pas si j'ai plusieurs immobilisations avec le même numéro de PCG. La fonction s'arrête toujours sur le 1er résultat trouvé, alors qu'il y en a 2 (ou plus...)

Y a t-il un moyen de les additionner? Quand j'ai testé en additionnant 2 fois la formule, il m'additionne deux fois le même résultat (le 1er bien sur). Le deuxième n'existe pas pour lui...

Ca me bloque énormément. Merci d'avance si vous pouvez m'aider!

2 réponses

Messages postés
16376
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 janvier 2021
3 118
Bonjour

par exemple

tes PGC dans A2:A100, tes HT dans B2:B100, le N° PGC cherché en C2

=SOMME.SI(A2:A100;C2;B2:B100)
Re,

Merci à toi! Je viens d'essayer et ça marche nickel! C'est en plus beaucoup plus simple qu'avec des RECHERCHEV.

Je pense que cette formule me servira ailleurs...

Merci pour la rapidité, ça pouvait pas mieux tomber ;)