Excel 2003 Résultat d'une fonction incorrect [Résolu/Fermé]

Signaler
-
 Utilisateur anonyme -
Bonjour,

Suite à une fonction complexe [Somme(Si(@3condition)], la fenêtre "Arguments de la fonction" me renvoi pour la fonction "Somme" un résultat en bas de la fenêtre, juste au dessus du lien vers l'aide, qui est juste .
Je dis YES ! ;-)

Le problème vient du fait que ce n'est pas celui qui apparait dans ma cellule une fois que j'ai validée la fenêtre "Arguments de la fonction".

Avez-vous des idées....
Je prends tout, au point où j'en suis.

Merci @ vous
Thor

5 réponses

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
834
Salut le forum

Le mieux serait de voir la formule complète

Mytå

La voici en version simplifiée :
=SOMME(SI((B6:B23=E6)*(C6:C23>=G32)*(C6:C23<G33);1;0))

Et dans ce cas, le résultat est bon, mais la valeur affichée est "#VALEUR!"

L'idée est de sommer le nombre d'occurrence, égale en B et dont la date C est comprise entre 2 valeurs (pour un mois).

@ vous
Thor
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
828
Bonsoir à tous,
As-tu validé ta formule par CTRL+MAJ+ENTER?
Sinon, tu pourrais avantageusement passer par des SOMMEPROD()
Cordialement

Merci JvDo !

Pour ma "petite" (in)formation, @ quoi correspond CTRL+MAJ+ENTER ?
Quand doit-on l'utiliser ?

Encore merci
Thor
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
834
Re le forum

On valide une formule matricielle, dans une ou dans plusieurs cellules d'un coup, en utilisant la combinaison [Ctrl]-[Maj]-[Entrée], ce qui les rend inaccessibles à ceux qui frappent sur leur clavier avec un seul doigt !

Le calcul matriciel permet de faire des opérations entre matrices.

Pour la liste des fonctions une petite recherche sur Google.

Mytå
Ok, merci pour ce petit cours accéléré.

Si du coup, on souhaite copier-coller une formule matricielle, est-ce possible ?
J'ai essayé la manière "brute" mais cela ne marche pas.

Thor

Edit Ok ca marche pardon

Bonne bourre à vous pour la suite et merci pour le forum/