Excel:Somme 1 case sur 60, faire glisser?

[Fermé]
Signaler
-
Messages postés
24183
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2021
-
Bonjour,
Je dois faire une somme toutes les 60 lignes des 60 lignes precedentes. Jusque la rien de difficiles sauf que j'ai plus de 165000 lignes. Je vous laisse faire le calcul du nombre de somme a effectue ainsi que le temps necessaire pour le faire.
Y a t-il un moyen de faire rapidement ces sommes? (un truc du genre faire glisser...)
Cordialement

Phill



2 réponses

Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
882
Salut le forum

Tes valeurs de A1 à Ax

En C1, à recopier vers le bas
=SOMME(DECALER(A1;59*(LIGNE()-1);;;):DECALER(A60;59*(LIGNE()-1);;;))

Tu auras en C1 la somme de A1:A60, en C2 la somme de A61:A120 ...

En prime en D1 tu peux mettre, à recopier vers le bas
="Somme(A" & 60*(LIGNE()-1)+1 & ":A" & 60*(LIGNE()-1)+60 & ")"


Mytå


Merci de donner suite à votre question, nous ne sommes pas des robots...
Versions installées [MsProject 2003(FR), Excel 2003-2007(FR)]
Messages postés
24183
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2021
6 892
Bonjour,

Ou bien pour recopier tu sélectionnes x lignes au dessus en plus de ta formule.
Ex pour une somme toutes les 4 lignes :
- en B5: =SOMME(A2:A5)
- sélectionner B2:B5 et tirer vers le bas (ou double-clic sur la poignée de recopie s'il n'y a pas de vide en colonne A)

eric