Recherche formule excel [Résolu/Fermé]

Signaler
Messages postés
116
Date d'inscription
vendredi 7 septembre 2007
Statut
Membre
Dernière intervention
6 novembre 2013
-
Messages postés
116
Date d'inscription
vendredi 7 septembre 2007
Statut
Membre
Dernière intervention
6 novembre 2013
-
Bonjour,

Je suis à la recherche d'une formule excel pour ameliorer mon fichier. j'ai besoin de votre aide car la je bloque.
Exemple:

Colonne A : les dates de l'année
Colonne B : soit il y a un chiffre soit les cellules sont vides

Mon probleme c'est que j'aimerai savoir le nombre max de cellules vides consecutives.

J'attends vos suggestions. Merci d'avance

5 réponses

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
810
Salut le forum

Dans la colonne C, nous pouvons utiliser la formule suivante (pour la cellule C2) :
=SI(ESTVIDE(B2);1+N(C1);"") 

Pour afficher le nombre maximal de cellules vides consécutives, il ne reste plus qu'à utiliser une formule du type =MAX()

Mytå
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
810
Re le forum

Ajoute une condition sur la date

=SI(ET(ESTVIDE(B2);A2<AUJOURDHUI());1+N(C1);"")

Mytå
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
116
Date d'inscription
vendredi 7 septembre 2007
Statut
Membre
Dernière intervention
6 novembre 2013
1
Merci pour votre reponse Myta , mais je n'arrive pas à appliquer la formule.Je ne suis peux etre pas assez doué.
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
810
Re le forum

As-tu recopié la formule vers le bas dans la colonne C ?

Pour joindre un fichier, tu crèes un lien à l'aide de
https://www.cjoint.com/ ou de http://cijoint.fr/ et tu
recopies le lien dans ton prochain message.

Mytå
Messages postés
116
Date d'inscription
vendredi 7 septembre 2007
Statut
Membre
Dernière intervention
6 novembre 2013
1
ça y est j'ai réussi , je n'avais pas fais glisser la fomule jusqu'en bas de la colonne C. Par contre j'ai un nouveau probleme!!!!

Etant donné que les cases des jours à venir son vide , la formule me dit que le plus gros ecart = aujourd'hui jusqu'a la fin de l'année!!!
Messages postés
116
Date d'inscription
vendredi 7 septembre 2007
Statut
Membre
Dernière intervention
6 novembre 2013
1
Bonjour Myta,

Je vous remercie pour votre aide si precieuse.La formule correspond exactement à ce que je voulais.Merci encore!!!!