Recherche sur deux colonnes Excel (matrice) [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mardi 20 juillet 2010
Statut
Membre
Dernière intervention
20 juillet 2010
-
 moha -
Bonjour,

Ne trouvant pas la réponse à ma question j'ai décidé de créer un post.

J'ai un fichier excel contenant plusieures colonnes de A à J.

Plus simplement, dans la colonne A j'ai des données que l'on appellera "péres" et dans la colonne B des données que l'on appellera "fils".

Je chercher a identifier les "fils" des "péres" sachant qu'un fils peut aussi se retrouver en colonne a comme "pére". L'identifiant qui lui correspondait devient donc le "grand pére".

Exemple:

Colonne A (péres) Colonne B (Fils)
A AB
B BB
C CB
D DB
AB ABC
BB BBC
CB CBC
DB DBC

A est donc la donnée pére de AB (avec une recherchev ça pourrait facilement marcher), mais AB est aussi pére de ABC.... A est donc grand pére de ABC.

Je souhaiterai trouver une formule simple ou sous forme matricielle qui puisse me donner pour chaque grand pére son fils et son petit fils. A AB ABC - B BB BBC -.....

J'éspére que quelqu'un comprendra ma recherche.

Merci à tous,

Cordialement,



office 2003 -Excel.

1 réponse

Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
763
bonjour,

soit je n'ai pas compris, soit cela doit fonctionner :
=RECHERCHEV(B1;$A$1:$B$8;2;FAUX) en colonne C renvoie le fils de la colonne B donc le petit fils de la colonne A

la même formule 'propre' c a d avec détection d'erreurs de recherche :

=SI(ESTERREUR(RECHERCHEV(B1;$A$1:$B$8;2;FAUX));"";RECHERCHEV(B1;$A$1:$B$8;2;FAUX))
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
763
et pour avoir directement le petit fils :
=SI(ESTERREUR(RECHERCHEV(RECHERCHEV(A1;$A$1:$B$8;2;FAUX);$A$1:$B$8;2;FAUX));"";RECHERCHEV(RECHERCHEV(A1;$A$1:$B$8;2;FAUX);$A$1:$B$8;2;FAUX))
Messages postés
2
Date d'inscription
mardi 20 juillet 2010
Statut
Membre
Dernière intervention
20 juillet 2010

Merci pour l'aide, c'est presque ça.
En fait un pére ayant plusieurs fils il suffisait de retourner la formule en cherchant le pére du fils. Pas bien compliqué, suffisait d'y penser. Excel c'est de la logique aprés tout.
Je ferme le post.
A bientot.
bonsoir ;
svp il a inproblem de man trvaille commant triee un date fixe exmple 13/08/2008 dans une fuil de recherche ; qui ce trouve dans plusieurs fuills