Excel ne pas afficher les heures négatives

[Résolu/Fermé]
Signaler
Messages postés
9
Date d'inscription
jeudi 1 juillet 2010
Statut
Membre
Dernière intervention
15 juillet 2010
-
Messages postés
9
Date d'inscription
jeudi 1 juillet 2010
Statut
Membre
Dernière intervention
15 juillet 2010
-
Bonjour,

Au lieu d'avoir une heure négative, est-il possible que la cellule reste blanche ou qu'elle affiche un 0 et lorsque l'heure est positive qu'elle soit sous cette forme ex. 02:00


Merci



4 réponses

Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Bonjour
si l'affichage est le résultat d'une opération, soit A1-B1 pour l'exemple:
=SI(B1>A1;"";B1-A1)
avec une cellule en format "heure"
Crdlmnt
Messages postés
9
Date d'inscription
jeudi 1 juillet 2010
Statut
Membre
Dernière intervention
15 juillet 2010

Merci
Messages postés
17232
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
16 septembre 2021
10 579
Bonjour,

Je pense que le plus simple du plus simple ;) est de mettre un format numérique avec 0 pour les nombres négatifs :

Format, Nombre => Personnalisé
hh:mm;0;0

Ainsi pas besoin de formule !

m@rina

Hello Vaucluse ! ;) Matinal pour ce 14 juillet... T'as été défiler ? ;))))
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Hello M@rina
éh bé non tu sais, moi dans ces cas là je suis plutôt du genre à me défiler.
bien le coup du format. C'est vrai que je ne suis pas un adepte de ces solutions. Faudrait que je m'y mette, mais fait chaud ces temps ci...
bises
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
880
Salut le forum

Juste pour explication :

Un format de nombre peut comporter jusqu'à quatre sections de code, séparées par des points-virgules. Ces sections définissent, dans l'ordre, les formats des valeurs positives, des valeurs négatives, des valeurs zéro et du texte.

<VALEUR POSITIVE>;<VALEUR NÉGATIVE>;<VALEUR ZÉRO>;<TEXTE>

Vous pouvez par exemple utiliser ces sections de code pour créer le format personnalisé suivant :

[Bleu]#,##0,00_);[Rouge](#,##0,00);0,00;"ventes "@

Bonne Journée !

Mytå
Messages postés
9
Date d'inscription
jeudi 1 juillet 2010
Statut
Membre
Dernière intervention
15 juillet 2010

Merci pour l'info.
Messages postés
9
Date d'inscription
jeudi 1 juillet 2010
Statut
Membre
Dernière intervention
15 juillet 2010

Excellent, simple et efficace