Excel (fonction recherche et test logique)

Résolu/Fermé
Signaler
-
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
-
Bonjour, je cherche à compléter ma fonction rechercher afin que ma rechercher ne se répète pas par rapport à ma recherche précédente

ma fonction simple
=RECHERCHE($A$2;'heure affecté chantier'!$C$3:$C$184;'heure affecté chantier'!$F$3:$F$184)

la fonction modifie pour éviter les répétition (mais elle ne fonction pas elle m'envoie l'erreur(#valeur))

=SI(RECHERCHE($A$2;'heure affecté chantier'!$C$3:$C$184;'heure affecté chantier'!$F$3:$F$184);(RECHERCHE($A$2;'heure affecté chantier'!$C$3:$C$184;'heure affecté chantier'!$F$3:$F$184)<>A14);"")

1 réponse

Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
890
Salut le forum

La fonction Recherche va toujours te donner la première valeur trouvée.

Resultat : La plage du résultat
Code : La palge du code à rechercher

Formule matricielle a valider par CTRL+SHIFT+ENTER
=SI(LIGNES($1:1)<=NB.SI(Code;$E$6);INDEX(resultat;PETITE.VALEUR(SI(Code=$E$6;LIGNE(INDIRECT("1:"&LIGNES(Code))));LIGNES($1:1)));"")  


Mytå

Versions installées [MsProject 2003(FR), Excel 2003-2007(FR)]