Compteur de cases remplies sur excel

Résolu/Fermé
Signaler
-
 Drix -
Bonjour,

Je sais que ce que je vais demander au niveau excel est aussi simple que de se pisser sur les chaussures, mais bon pour excel je n'y arrive pas encore...

Ce que j'ai :
- une colonne avec des cases remplies par des nombres ou par rien
- une colonne dans laquelle je fais apparaître un 1 (si la case de la colonne citée juste au dessus est remplie) ou un 0 (dans le cas contraire) grâce à la formule
=SI(ESTVIDE("case de la colonne précédente"); "0"; "1")

Ce que je veux faire : avoir juste un décompte du nombre de cases remplies de la première colonne (j'ai conscience que la 2ècolonne est peut-être complètement inutile... mais je pensais faire une somme des "1" affichés, et avec ma formule la somme donne un "0"....).

Je vous remercie de bien vouloir aider un tel néophyte.

Salutations.


Drix

3 réponses

Messages postés
17814
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 janvier 2022
4 913
Salut,

Je crois avoir compris la demande, pour compter les cellules non vide

pour une plage déterminée de A1 à A30 par ex. =NBVAL(A1:A30)
pour toute la colonne =NBVAL(A:A)

pour compter une valeur exemple 125 sur la plage A1 à A 30 =NB.SI(A1:A30;125 )
ou pour toute la colonne =NB.SI(A:A;125 )

pour compter du texte ex le mot toto la formule est =NB.SI(A1:A30;"toto" )

ou pour la colonne =NB.SI(A:A;"toto" )

Pour compter les cellules vides =NB.VIDE(A1:A30)
ou pour la colonne =NB.VIDE(A:A)

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
17
ok je prends aussi ça me servira merci!
0
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 304
Bonjour,

ta somme de donne un 0 car en précisant "0";"1" dans tes conditions, le résultat dans ta case est en format texte vu que tu as utilisé des guillemets.
Enlève les guillemets dans ta formule de base, et recommence ta somme, tu devrais normalement obtenir le résultat que tu cherchais.

Cordialement.
1
Merci Chossette!
résolu!
0
Messages postés
55353
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
17 223
Bonjour Drix.

Comme tu le supposes à juste titre, on peut se passer de la deuxième colonne, en écrivant les formules
=NB.SI(A2:A51;"") pour avoir le nombre de cellules vides et
=50-NB.SI(A2:A51;"") pour avoir le nombre de cellules renseignées, si les 50 cases concernées vont de A2 à A51.
1
OK merci ca marche aussi merci Raymond!
0