[Excel] Compter des valeurs [Résolu/Fermé]

Signaler
Messages postés
2289
Date d'inscription
mercredi 1 octobre 2003
Statut
Contributeur
Dernière intervention
1 octobre 2007
-
 Marie-Josée -
Bonjour à tous,

J'aurais aimé savoir s'il existe une fonction permettant de compter le nombre de valeurs différentes dans une colone. En gros, j'ai 540 lignes, et chaque valeur se répète plusieurs, j'aurais aimé savoir s'il n'y a pas un moyen de ressortir uniquement le nombre de chiffres différents.

Par exemple, sur ces 540, il doit y en avoir environ 200 différentes. Je n'ai pas trouvé de fonction par l'invite d'Excel, et j'aimerais éviter de créer un macro pour ça...

Mais si c'est la seule solution, je m'y collerai ;)

@+

14 réponses

Messages postés
52357
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
14 176
Bonsoir, Erdnax (il est 22 h chez moi).

Comme l'indique random, il faut trier ta colonne.
Par précaution, je te conseille de ne pas travailler sur ton fichier original, mais sur une copie que tu supprimeras ensuite.
Nous utiliserons l'assistant "Sous-total". Allons-y :

1) Faire une copie du fichier
2) Effectuer un tri du tableau par rapport à la colonne contenant ces valeurs (par exemple colonne C, avec comme intitulé "Prix" en C1, et les différentes valeurs à partir de C2 jusqu'à C541, sans sauter de ligne)
3) Cliquer Données / Sous-totaux... : La boîte de dialogue "Sous-total" apparaît.
4) Dans la fenêtre 2 Utiliser la fonction choisir Nb à la place de Somme. Ne pas modifier le reste et faire OK
5) Excel déplace la colonne "Prix" et insère une colonne portant les intitulés "Nombre xxx", et à côté, dans la cellule "Prix", le nombre d'occurrences de chaque valeur xxx
6) En supposant que le total général, indiqué par l'intitulé "Nbval", soit à la ligne 559, se placer en C560 et saisir "=NBVAL(C2:C558") : Tu as ta réponse !

Fais-moi savoir si ça a marché.

Raymond
14
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Il suffit d'utiliser la formule suivante (si la plage sur laquelle tu recherches est A2:A500)
=somme(1/NB.SI(A2:A500 ;A2:A500))
Comme c'est une matricielle, pour valider la formule il faut taper ctrl+maj+entrée.
> ludo
Merci

Cela fonctionne parfaitement !

Très utile!

Merci beaucoup Raymond

Il y aurait une autre façon de voir la fréquence de chaque occurrence de votre liste : la fonction FREQUENCE.

Par contre, pour voir cette fonction, il faut aller dans Fichier, Options, Compléments, bouton Atteindre, puis activer le complément Analysis Toolpack.
J'ai recement deposé sur le site VBFRANCE deux nouvelles fonctions excel qui répondent a ta demande.
Pas besoin de trier ni de triturer la feuille. il suffit d'incorporer le code VBA de ces fonctiions dans ton classeur
et ensuite d'utiliser ces fonctions comme toutes les autres fonctions Excel.

Les doublons triplons ..... peuvent etre contigus ou non, c'est prévu dans la fonction.

Il y a une fonction pour compter le nombre d'occurences non nulles et différentes dans une plage de cellules
NBVAL_DISTINCT
et une autre si on a filtré la plage pour compter le nb d'occurences non nulles, différentes et visibles.
NBVAL_DISTINCT_VISIBLE

exemple
= NBVAL_DISTINCT(A1:A666)

Voir le lien :
https://codes-sources.commentcamarche.net/
Je ne suis pas un pro d'excel mais si tu cherches le nombre de valeurs differentes dans une colonne, je copierais la colonne quelque part, selcetionner cette nouvelle colonne, supprimer les doublons, puis appliquer un simple NBVAL sur cette colonne.
Supposons les données en colonne A à partir de la cellule A2
Trier de A2 à la fin
En colonne B2, mettre la formule suivante:
=SI(A2<>A1;1;0)
Recopier cette formule vers le bas ce qui met la valeur 1 à chaque changement de valeur
Faire la somme de la colonne B avec la formule suivante:
=somme(B:B)

Ceci marche pour tous les types de valeur...
Messages postés
4415
Date d'inscription
mercredi 26 janvier 2005
Statut
Membre
Dernière intervention
24 mai 2013
742
il faut utiliser un tableau croisé dynamique pour faire resortir tes valeurs

cerelog
Messages postés
1612
Date d'inscription
vendredi 26 novembre 2004
Statut
Membre
Dernière intervention
30 mars 2006
145
on trie la colonne
on met en place la formule suivante
si (maligne=ligne-1;1;0)
et on somme
Bonjour,

J'ai essayé la formule de michel mais sans succès, je retrouve l'erreur valeur dans ma case de résultats. Pourtant j'ai fais copier/coller et j'ai modifié les plages de valeurs... Si qqun a une idée merci bcp
>
Messages postés
23507
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020

en fait j'avais une formule sur excel mais ca a pas l'air de marcher sur Ooo:

=SOMME(SI(FREQUENCE(SI(NBCAR(B4:B500)>0;EQUIV(B4:B500;B4:B500;0);"");SI(NBCAR(B4:B500)>0;EQUIV(B4:B500;B4:B500;0);""))>0;1))

même sur excel, c'était pas très stable :(

essayez =(B2, DTC)
Merci eriic ça marche super
Messages postés
6
Date d'inscription
mardi 23 octobre 2012
Statut
Membre
Dernière intervention
31 octobre 2013

Bonjour,

Est-il possible d'adapter ta formule =SOMMEPROD((FREQUENCE(B2:B28;B2:B28)>0)*1) en langage VBA en utilisant WorksheetFunction ? j'ai essayé en vain jusqu'à maintenant..
Messages postés
23507
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020
6 374
Bonjour,

En vba il faut écrire les fonctions en anglais, et utiliser le séparateur , au lieu de ;
Le plus simple est de valider la formule sur la feuille en enregistrement de macro. Ca te donnera la traduction des fonctions.

eric
Messages postés
146
Date d'inscription
mercredi 9 janvier 2008
Statut
Membre
Dernière intervention
23 mars 2015
10
Bonjour,

Je pense qu'il faut utiliser une formule comme celle-là :

=SOMMEPROD(1/NB.SI(D9:D23;D9:D23))

Où D9:D23 est la plage de données où se trouvent les valeurs différentes ou non les unes par rapoort aux autres.

Espérant que cela fonctionne dans ton cas,

Bonne continuation.
Messages postés
2289
Date d'inscription
mercredi 1 octobre 2003
Statut
Contributeur
Dernière intervention
1 octobre 2007
486
Qu'est ce que tu entends par ligne-1 ?

T'arrive à me montrer un exemple de ce que ça peut donner ? Même complètement fictif, comment tu fais pour retourner à la ligne précédente ?
Je pense que cette solution (maligne-1) ne marche pas, j ai le meme probleme et si j applique cela j ai par exemple :
5
5
5
5
4
4
5
5
5
Il va compter 3 alors qu il y a que 2 valeurs différentes...
Messages postés
52357
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
14 176
C'est encore moi.

Notre ami qmike a parfaitement raison. Le blog "Astuces Michel" est d'ailleurs remarquable, exhaustif, clair, bien organisé.

J'avoue que je ne connaissais pas la formule qu'il propose, mais je l'ai testée et elle marche au poil !

Mais enfin ma prose concernant SOUS-TOTAL pourra toujours te servir à une autre occasion ...

Salut, Raymond
Regarde si tu n'as pas une version anglaise d'Excel. Au quel cas tu devras trouver la traduction de la formule.
Bonjour,

Mon premier livrable sur un forum.

Imaginons que ta colonne en A ait des doublons, triplons, quadruplons,...
faire un trie croissant de la colonne A
insérer une ligne en haut
insérer quatre colones B, C, D et E
en B
=SI(A2=A1;1;0)
en C
=SI(B2=0;1;0)
en D
=SI(ET(C2=0;B2=1);D1+1;1)
en E
=SI(ET(B2=1;B3=0);D2;SI(ET(B2=0;B3=0);1;""))

On peut surement faire mieux, mais ça, ça marche.
Cordialement.
Messages postés
2289
Date d'inscription
mercredi 1 octobre 2003
Statut
Contributeur
Dernière intervention
1 octobre 2007
486
Salut,

Merci pour ta réponse, mais en fait, je m'en suis sortis avec des sommes, sommes.si, et nb ;)

@+