Problème avec la protection htaccess

Fermé
Signaler
Messages postés
178
Date d'inscription
lundi 11 janvier 2010
Statut
Membre
Dernière intervention
21 mars 2011
-
Messages postés
178
Date d'inscription
lundi 11 janvier 2010
Statut
Membre
Dernière intervention
21 mars 2011
-
salut

j'ai un problème avec l'authentification htaccess qui ne marche pas.

je veut protéger un dossier contenant des page web de telle sorte en accédant à la page index.php,j'aurais une page d'authentification qui me permet de saisir le login et le mot de passe.
le dossier contenant les pages web se trouve dans: /var/www/pfe

j'ai créé un fichier ".htaccess" contenant les lignes suivantes:
AuthName "Veuillez saisir votre login et votre mot de passe"
AuthType Basic
AuthUserFile "/var/www/pfe/.htpasswd"
Require valid-user

et j'ai créé le fichier .htpasswd contenant la ligne suivante du login et le mot de passe crypté:
lam:$1$1J.jFDND$9W6Z36OKASLh..meH0yGF0


les fichier .htaccess et .htpasswd se trouvent trouve dans /var/www/pfe


quand j'essay à travers le navigateur d'écrire ceci:
http://localhost/pfe/index.php

il accède directement à la page sans aucune authentification


aidez moi svp à régler le problème

merci d'avance

1 réponse

Messages postés
60
Date d'inscription
lundi 31 mai 2010
Statut
Membre
Dernière intervention
29 juillet 2010
6
Es-tu certain que l'.htaccess est lu par le serveur? Pour tester, introduit une erreur volontaire dans ce dernier, comme par exemple:

AuthTOTOName blabla

Si le serveur t'envoie un "Internal sever error" c'est qu'il est lu. Sinon vérifie la valeur de la directive AllowOverride pour ce répertoire dans les fichiers de config.
Messages postés
178
Date d'inscription
lundi 11 janvier 2010
Statut
Membre
Dernière intervention
21 mars 2011

salut
j'ai rajouté l'erreur dans le htaccess et j'ai resaisi http://localhost/pfe/index.php

mais rien ne se passe le contenu de la page s'affiche normalement.

comment pourai je vérifier le AllowOverride pour ce répertoire dans les fichiers de config??

merci
Messages postés
60
Date d'inscription
lundi 31 mai 2010
Statut
Membre
Dernière intervention
29 juillet 2010
6
Tu te mets dans le répertoire des fichiers de config de ta distro (laquelle?), par exemple /etc/apache2 et tu fais
grep -ri allowoverride *

Tu ouvres le fichier de config qui te concerne et tu mets AllowOverride All
Messages postés
178
Date d'inscription
lundi 11 janvier 2010
Statut
Membre
Dernière intervention
21 mars 2011

j'ai exécuté ceci, j'ai eu comme résultat: (j'ai apache2)
apache2.conf:# for additional configuration directives. See also the AllowOverride
apache2.conf:# AllowOverride None
conf.d/security:# AllowOverride None
mods-available/alias.conf: AllowOverride None
mods-available/userdir.conf: AllowOverride FileInfo AuthConfig Limit Indexes
mods-enabled/alias.conf: AllowOverride None
sites-available/default: AllowOverride None
sites-available/default: AllowOverride None
sites-available/default: AllowOverride None
sites-available/default: AllowOverride None
sites-available/default-ssl: AllowOverride None
sites-available/default-ssl: AllowOverride None
sites-available/default-ssl: AllowOverride None
sites-available/default-ssl: AllowOverride None
sites-enabled/000-default: AllowOverride None
sites-enabled/000-default: AllowOverride None
sites-enabled/000-default: AllowOverride None
sites-enabled/000-default: AllowOverride None



j'ai ouvert le fichier apache.conf

la seule place ou j'ai trouvé AllowOverride est:

Alias /error/ "/usr/share/apache2/error/"
#
# <Directory "/usr/share/apache2/error">
# AllowOverride None
# Options IncludesNoExec
# AddOutputFilter Includes html
# AddHandler type-map var
# Order allow,deny
# Allow from all
# LanguagePriority en cs de es fr it nl sv pt-br ro
# ForceLanguagePriority Prefer Fallback
# </Directory>


j'ai décomenté "AllowOverride None" et j'ai remplacé None par All, j'a
Messages postés
178
Date d'inscription
lundi 11 janvier 2010
Statut
Membre
Dernière intervention
21 mars 2011

j'ai eu cette erreur en redémarrant apache2:

* Restarting web server apache2 * We failed to correctly shutdown apache, so we're now killing all running apache processes. This is almost certainly suboptimal, so please make sure your system is working as you'd expect now!
... waiting .Syntax error on line 244 of /etc/apache2/apache2.conf:
AllowOverride not allowed here
[fail]

?????
Messages postés
178
Date d'inscription
lundi 11 janvier 2010
Statut
Membre
Dernière intervention
21 mars 2011

je c rois que je me suis trompé du fichier a configurer non??