Excel 2007 texte en fonction d'un resultat [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mardi 8 juin 2010
Statut
Membre
Dernière intervention
8 juin 2010
-
Messages postés
53854
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 mai 2021
-
Bonjour,

Voilà mon problème :

J'ai dans une cellule la date du jour (=AUJOURDHUI())

Dans une autre cellule la date de début d'un programme (exemple : 16/06/2010)

Dans une troisième cellule la date de fin d'un programme

Enfin dans une 4eme cellule j'aimerais pourvoir inscrire "EN COURS" "TERMINE" ou "A VENIR" selon la date du jour

Voilà la formule que j'ai essayé (mais qui ne marche pas) :

=SI(B4<$C$1<B5;"EN COURS");SI(B4>$C$1;"A VENIR");SI($C$1>B5;"TERMINE")

C1 : Date du jour
B4 : Date de début
B5 : Date de fin

Merci de votre aide !

2 réponses

Messages postés
53854
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 mai 2021
15 862
=SI($C$1>C3;"TERMINE";SI($C$1<B3;"A VENIR";"EN COURS"))

Un peu plus court ...
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 315
Certes Raymond tu as raison, pourquoi faire compliqué quand on peut faire simple ?

Sinon ça va les Antilles ? Il fait bon ?
Messages postés
53854
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 mai 2021
15 862
Oui, chossette9, en ce moment il fait beau et chaud (31°C).
Pour parvenir à faire simple, on dira pour optimiser ce type de formule conditionnelle, il ne faut pas avoir honte de faire un croquis rapide, un petit ordinogramme : ça aide considérablement à organiser son raisonnement et à écrire sa formule ...
https://www.cjoint.com/?giqNIr2bdk
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 315
Bonjour,
=SI(ET(B4<$C$1;$C$1<B5);"EN COURS";SI(B4>$C$1;"A VENIR";SI($C$1>B5;"TERMINE";"")))


Cordialement.
Messages postés
2
Date d'inscription
mardi 8 juin 2010
Statut
Membre
Dernière intervention
8 juin 2010

Héhé ! J'étais pas très loin.

Un GRAND merci !

Bonne journée !