Disque dur externe + lecture seule + debian [Résolu/Fermé]

Signaler
Messages postés
301
Date d'inscription
jeudi 19 juin 2008
Statut
Membre
Dernière intervention
13 février 2018
-
Messages postés
301
Date d'inscription
jeudi 19 juin 2008
Statut
Membre
Dernière intervention
13 février 2018
-
Bonjour,

J'ai un problème avec ma débian 4.0. Je voudrais faire une sauvegarde de répertoire mais pouvoir utliser le disque dur sur tous les OS.
Lorsque je branche le disque dur WB My Book Essential sur Linux, le système le voit bien mais il est en lecture seule uniquement.
J'ai fais quelques recherche et on parle sur les forums de ntfs-3G. Je l'ai installé mais 1 il ne peux être monté et donc 2 je ne peux plus y accéder.
J'ai donc supprimé ntfs-3G et je peux donc revoir le contenu du disque mais je ne peux rien écrire.

J'ai dans mon fichier /etc/fstab :

/dev/sda4 /dd ntfs user,users,uid=root,auto 0 0

Merci par avance de vos réponses

5 réponses

Messages postés
373
Date d'inscription
vendredi 9 octobre 2009
Statut
Membre
Dernière intervention
17 août 2010
115
alors, premièrement, pour tout monter la commande est

mount -a

Ensuite, il faut avoir installé ntfs-3g

$ aptitude install ntfs-3g

Et pour finir, dans votre cas la ligne dans /etc/fstab sera :

/dev/sdb1 /media/MyBook ntfs-3g defaults 0 0

Avec ça, ça devrait marcher.

PS : avez vous bien créer le répertoire /media/MyBook au préalable ?
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

J'ai migré sur la 5.0 depuis quelques temps, donc je ne saurais confirmer de façon certaine. Mais il me semble qu'il n'y a pas de déclaration à affectuer dans /etc/fstab pour les disques et clef USB.
D'après mes souvenirs c'est HAL qui detecte le matériel et monte automatiquent le disque ou la clef USB avce les droits de l'utilisateur. Après tout c'est naturel pour un poste bureautique (pas pour un serveur).

Cordialement,
Messages postés
373
Date d'inscription
vendredi 9 octobre 2009
Statut
Membre
Dernière intervention
17 août 2010
115
Bonjour,

J'ai utilisé également un disque dur formaté en NTFS avec debian lenny.

Pour cela, j'ai utilisé les drivers ntfs-3g.

Pour monter le disque, il faut l'annoncer dans le fichier /etc/fstab.
Mais avant toute chose, il faut l'identifier (/dev/sdb1 ? /dev/sda4 ? /dev/sdc ?). Honte à moi, je ne connais pas la commande, alors j'utilise gparted.

Voici la structure d'une ligne dans le fstab :

Nom du périphérique | point de montage | type | options | dump-freq | pass-num

Par exemple :

/dev/sdb /mnt/disque_USB ntfs-3g defaults 0 0

Il faut naturellement créer le répertoire avant de monter le disque, dans mon exemple :

$ mkdir /mnt/disque_USB

Puis on le monte :

$ mount -a

Habituellement, on monte les disque externe soit sur /mnt soit sur /media. Sous gnome, un disque monté dans le dossier /media/ sera représenté sur le bureau. Ce qui n'est pas le cas d'un disque monté sous le /mnt.
Messages postés
301
Date d'inscription
jeudi 19 juin 2008
Statut
Membre
Dernière intervention
13 février 2018
5
Merci de vos réponses à tous les 2.

Néanmoins, j'ai toujours le même pb ou presque :

J'ai modifié la ligne
/dev/sda4 /dd ntfs user,users,uid=root,auto 0 0


en
/dev/sdb1       /media/MyBook   ntfs    user,users,uid=root,auto,rw,exec     0   0


Lorsque je tape "mount" dans le terminal, j'obtiens :

/dev/sdb1 on /media/MyBook type ntfs (rw,nosuid,nodev,uid=0)


Si je mets
defaults
à la place de
user,users,uid=root,auto,rw,exec
, j'obtiens simplement

/dev/sdb1 on /media/MyBook type ntfs (rw)


Mais le résultat est le même si je vais voir les propriétés du disque, il me mets

"Les permissions de MyBook ne peuvent être déterminées".

De plus il y a toujours un verrou sur les répertoire présents sur le disque et ils sont toujours en lecture et exécution mais pas en écriture.

Merci de votre aide.
Messages postés
301
Date d'inscription
jeudi 19 juin 2008
Statut
Membre
Dernière intervention
13 février 2018
5
Super,

Merci cela a l'air de marcher.

Par contre si je saisis
mount -a
, il me renvoit :

WARNING: Deficient Linux kernel detected. Some driver features are
         not available (swap file on NTFS, boot from NTFS by LILO), and
         unmount is not safe unless it's made sure the ntfs-3g process
         naturally terminates after calling 'umount'. If you wish this
         message to disappear then you should upgrade to at least kernel
         version 2.6.20, or request help from your distribution to fix
         the kernel problem. The below web page has more information:
         http://ntfs-3g.org/support.html#fuse26</code>


Mais pour l'instant, cela marche.