Excel: Renvoi d'une valeur pour 2 conditions

[Résolu/Fermé]
Signaler
-
 Bedwyr -
Bonjour a tous,
Voila, je seche un peu sur excel.
J'ai un tableau a 3 colonnes et un nombre important de ligne. Je souhaite que la formule me renvoie la valeur de la 3e colonne dans le cas ou les 2 valeurs des 2 premieres colonnes se trouvant sur la meme ligne soit egale a des valeurs predefinies.
Je ne sais pas si c'est tres clair.

A B C
1 test1 truc1 valeur1
2 test1 truc2 valeur2
3 test2 truc3 valeur3
4 test3 truc1 valeur4
5
6 condition1
7 condition2

En gros si la valeur de condition1 = test1 et que la valeur de la condition2 = truc2, je voudrais que la formule me renvoie valeur2.
J'ai essaye une formule du type:
={SI((A6=A1:A4)*(A7=B1:B4);C1:C4)}
Malheureusement ca ne fonctionne que pour la premiere ligne du tableau (si condition1=test1 et si condition2=truc1), dans tous les autres cas ca me renvoie 0.

Voila, si quelqu'un a une idee pour m'aider je lui en serais tres reconnaisant.
Bon week end a tous.

2 réponses

Messages postés
24205
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
6 938
Bonjour,

=SOMMEPROD(($B$2:$B$5=condition1)*($C$2:$C$5=condition2)*($D$2:$D$5))
Les plages doivent avoir la même taille.
eric
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Merci Eric ca fonctionne parfaitement