Excel: Somme de rechercheV noms similaire

Résolu/Fermé
Signaler
-
 remydel -
Bonjour,

J'ai un petit problème Excel à vous soumettre :

J'ai un excel avec deux feuilles :
Une feuille avec des données et une autre feuille avec laquelle j'aimerai exploiter ces données.
Avec la deuxième feuille, j'utilise la fonction recherche V pour récupérer les données de la feuille 1
J'aimerai trouver une formule qui me permette d'utiliser la fonction rechercheV en faisant la somme des cellules dont le nom est proche ou par exemple dont les 3 premiers caractères sont identiques.

Le classeur en question est dans le lien suivant pour plus de compréhension :
https://www.cjoint.com/?emncnFxWiS

Merci d'avance pour vos idées ;

Rémy

2 réponses

Messages postés
55093
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 décembre 2021
17 013
Plusieurs solutions sont possibles.
L'une d'entre elles consiste à
* saisir en C2 la formule =GAUCHE(A2;3)
* saisir en D2 la formule =SOMME.SI($C$2:$C$9;C2;$B$2:$B$9)
* recopier C2 et D2 vers le bas
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Merci pour cette réponse rapide;
l'idéal serait de trouver une formule qui lie Recherche V et Somme.SI;
Je suis encore débutant dans ce type de forumule, sauriez vous comment je pourrais les lier ?
Messages postés
26310
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 décembre 2021
6 131
Re
la formule RECHERCHEV ne trouvant jamais que la 1° ,igne de code du tableau, on ne voit pas bien comment l'associer à une somme ni ce que vous voulez faire en final.
Avez vous vu la proposition ici?
https://forums.commentcamarche.net/forum/affich-17344578-excel-somme-de-recherchev-noms-similaire#2
Crdlmnt
Messages postés
26310
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 décembre 2021
6 131
en complément à ce message, ,la formule ci dessous, en C2 sur la feuille exploitation, vous donnera le résultat attendu:
=SOMME.SI(Données!$A$2:A9;"*"&A2&"*";Données!$B$2:$B$9)
à tirer sur la hauteur voulue
Crdlmnt
Merci pour cette formule me permettant de trouver seule le bon résultat;
Merci de votre aide!
Messages postés
26310
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 décembre 2021
6 131
Bonjour
vous pouvez essayer aussi, par exemple pour faire le total des correspondants aux nom contenant Be:
SOMME.SI(A1:A10;"*Be*";B1:B10) vous donnera le total de tout ce qui contient Be n'importe où
"*Be" cherchera tout ce qui finit par Be
"Be*" .. tout ce qui commence par Be
Crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci