Faire une somme.si.ens sur excel 2003

Résolu/Fermé
eloddy - 9 avril 2010 à 23:11
 eloddy - 11 avril 2010 à 14:19
Bonjour,

J'ai lu les messages précédents mais n'arrive pas à les transposer à mon cas. Je veux faire un somme.si avec plusieurs critères, sur Excel 2003.

Les conditions sont avec du texte. Par exemple.

A B C D
Age Nombre Nationnalité Client
adulte 1 française oui
enfant 2 française oui
senior 1 marocain oui
adolescent 4 italien non
adulte 10 française oui
adulte 5 américain non
enfant 2 japonais non
adulte 2 japonais oui

Je veux par exemple calculer le nb d'adultes français client de mon entreprise.
Sur Excel 2007, j'aurais fait la formule suivante :
=SOMME.SI.ENS(B:B;A:A;"adulte";C:C;"française";D:D;"oui")

Mais sur Excel 2003 je n'arrive pas à trouver d'équivalent
Merci d'avance pour vos conseils....!

3 réponses

argixu
Messages postés
4810
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
20 mars 2022
4 455
Modifié par argixu le 9/04/2010 à 23:47
Bonjour

et avec
=SOMMEPROD((($A$2:$A$9="adulte")*($C$2:$C$9="française")*($D$2:$D$9="oui")))

avec sommeprod, tu ne peux pas faire sur une colonne entière
Argitxu
0
Merci
J'ai essayé également cette formule mais sommeprod n'est pas pris en compte dans excel 2003 je crois.

Là je suis en train d'essayer de concatener les colonnes entre elles et de faire ensuite un somme.si, je pense que ça peut marcher, mais c'est un peu long !
0
Raymond PENTIER
Messages postés
56112
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 mai 2022
17 209
11 avril 2010 à 03:03
"mais sommeprod n'est pas pris en compte dans excel 2003 je crois."
FAUX !
As-tu essayé ? Si oui, as-tu bien respecté la syntaxe ? Regarde bien les formules de tontong et argixu ...
0
tontong
Messages postés
2514
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
25 mai 2022
1 024
10 avril 2010 à 11:40
Bonjour,
Quand vous aurez goûté à Sommeprod vous ne pourrez plus vous en passer ;-)
Cette formule existait déjà bien avant Excel 2003, elle était seulement un peu limitée a ses débuts par les performances des processeurs.
Mon intervention consistera seulement à compléter la formule d'Argixu qui a perdu la colonne B en chemin.
SOMMEPROD((($A$2:$A$200="adulte")*($C$2:$C$200="française")*($D$2:$D$200="oui")*($B$2:$B$200)))
Les champs peuvent être étendus, une seule contrainte: ils doivent tous avoir la même dimension.
0
argixu
Messages postés
4810
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
20 mars 2022
4 455
10 avril 2010 à 13:09
Bonjour,
Un copié-collé oublié. Merci Tontong :-))
0
Super ça marche ! Merci bien pour vos réponses, je suis déjà devenue accro à sommeprod !
0