Macro VBA excel - équivalent d'autofill [Résolu/Fermé]

Signaler
-
Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
-
Bonjour,

Voici mon problème :
J'ai réalisé une macro par en enregistrement. A moment donné, j'ai besoin d'effectuer un autofill. Seulement, mon nombre de lignes varie à chaque fois et l'autofill conserve la valeur de l'enregistrement. J'ai donc écris quelques lignes permettant de remplacer cet autofill :

Dim i As Integer
Range("E2").Select
For i = 1 To 5000
If Range("D" & i).Value <> "" Then
Range("E" & i).Value = Range("E2").Formula
Else
Range("E" & i).Value = ""
End If
Next i

La cellule "E2" est une formule : =SI(D2>'Dates Séléct.'!A:A;"OK";"")
Mon problème est que je souhaite que la cellule "E3" soit égale à SI(D3>'Dates Séléct.'!A:A;"OK";""),"E4"=SI(D4>'Dates Séléct.'!A:A;"OK";"") etc etc... Or actulement E3, E4... sont toutes égales à SI(D2>'Dates Séléct.'!A:A;"OK";"")

Je pense que le problème se trouve au niveau de "Range("E2").Formula"...

Merci d'avance pour votre aide!

1 réponse

Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
570
Bonjour,
c'est une question en doublon, j'ai répondu ICI