Code postal excel

Résolu/Fermé
Signaler
Messages postés
38
Date d'inscription
samedi 6 juin 2009
Statut
Membre
Dernière intervention
22 octobre 2011
-
Messages postés
38
Date d'inscription
samedi 6 juin 2009
Statut
Membre
Dernière intervention
22 octobre 2011
-
Bonjour,
Est-il possible sous excel que en fonction du code postal écrit dans une cellule que la ville ou du moins les possibilités de ville soit renvoyer sur une autre cellule?
Merci

5 réponses

Messages postés
17695
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 851
Salut,

Oui c'est tout à fait possible avec la fonction RECHERCHEV.

Pour cela dans une colonne tu saisis les codes postaux et en face la ville correspondante. dans une cellule exemple la D1 te servira à saisir le code et en E1 tu colles cette formule

=RECHERCHEV(D1;A1:B6;2;0)

pour éviter le message d'erreur dans le cas de cellule vide il conviendrait d'écrire

=SI(D1<>"";RECHERCHEV(D1;A1:B6;2;0);"")

le problème est que plusieurs petites villes dépendent du même code postal, dans ce cas une formule matricielle complémentaire plus élaborée est nécessaire pour afficher toutes ces villes
Messages postés
38
Date d'inscription
samedi 6 juin 2009
Statut
Membre
Dernière intervention
22 octobre 2011

Ok. Merci vu que justement et c'est ce que je pensais les codes postaux sont de plusieurs villes ca ne va pas fonctionner pas grave. Merci
Messages postés
17695
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 851
Re,

Si ça fonctionne avec deux formules complémentaires.

Je vais donner un cours d'informatique mais dans la soirée au plus tard demain matin je te monte un exemple
Messages postés
17695
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 novembre 2021
4 851
Re,

Comme promis, regardes les diverses formules, surtout colonne G feuille 1 et 2

https://www.cjoint.com/?dkvGLLFda3
Messages postés
38
Date d'inscription
samedi 6 juin 2009
Statut
Membre
Dernière intervention
22 octobre 2011

Merci beaucoup =)