Fonctions logique Excel [Résolu/Fermé]

Signaler
Messages postés
35
Date d'inscription
mardi 9 février 2010
Statut
Membre
Dernière intervention
16 décembre 2020
-
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
-
Bonjour,

Je voudrais avoir dans une cellule une valeur donnée si la valeur d'une autre cellule se situe entre deux valeurs.
Ex :
E2 = 9 si B1=1
E2 = 11 alors BA=2 etc ...
Ce code là fonctionne mais je pense que l'on peut faire mieux d'autant plus qu'il est limité dans les valeurs
=SI(E2<=10;"1";SI(E2<=20;"2";SI(E2<=30;"3";SI(E2<=40;"4";SI(E2<=50;"5";SI(E2<=60;"6";SI(E2<=70;"7";SI(E2<=80;"8";SI(E2<=90;"9";SI(E2<=100;"10";))))))))))

3 réponses

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 314
Bonjour,

essaie avec ceci :
=ARRONDI.SUP(E2/10;0)

dans la case où tu dois mettre ta formule.

Cordialement,

Chossette9.
Messages postés
35
Date d'inscription
mardi 9 février 2010
Statut
Membre
Dernière intervention
16 décembre 2020

Pffff ... je suis trop bête !!! Je cherche la difficulté !

Merci !
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 314
De rien,

j'y ai assez rapidement pensé (coup de chance^^).

Par contre, une ou deux petites questions : est-ce que tu veux que cela fonctionne également pour les chiffres négatifs ? Les valeurs au-dessus de 100 ?
Sinon, lorsque ton chiffre est supérieur à 100 ou bien négatif, ta case doit rester vide ?

Cordialement,

Chossette9.