[UBUNTU]Serveur secondaire X+wow

Résolu/Fermé
Cynokine
Messages postés
98
Date d'inscription
mardi 10 juin 2008
Statut
Membre
Dernière intervention
9 février 2011
- 24 janv. 2010 à 13:58
 aprenti-linuxien - 30 oct. 2010 à 14:11
Bonjour, alors voilà, comme dit dans le titre j'aimerais faire tourner wow sur un serveur secondaire X j'ai suivi les manipulations de la doc seulement lorsque j'execute mon script, j'ai un ecran tout noir et je ne peut rien faire sauf éteindre l'ordi.
J'arrive en faire tourner wow juste avec wine mais j'ai des bugs et des deconnexions trop fréquentes. Je suis sous ubuntu 9.10 avec une carte graphique ATI, l'activation graphique est activé et tout. Je pense que le problème vient soit de l'affichage soit de mon script

Voici mon script que j'utilise pour lancer wow

Code:

#!/bin/bash

export WOW_PATH=~/.wine/drive_c/Program\ Files/World\ of\ Warcraft/ # Chemin d'installation

gksudo true || ( exit 1 ) # Valider le mot de passe
sudo X :3 -ac -terminate & # Lance sur un nouveau serveur X affichage 3
cd "${WOW_PATH}" # Cible le répertoire de WoW
sleep 2 # Attend 2 secondes que le serveur soit prêt
DISPLAY=:3 `which wine` WoW.exe -opengl # Lance WoW avec Wine et le paramètre OpenGL


pour lancer le serveur je fait juste bash "lenomduscript" et j'ai mon ecran noir

je met aussi le contenu de mon xorg.conf car je l'ai bidouiller et je ne pense pas qu'il soit correcte mais vu que j'y connais rien...

Code:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
EndSection

#Section "Screen"
# Identifier "Default Screen"
# Device "Configured Device"
# Monitor "aticonfig"
#DefaultDepth 24
# SubSection "Display"
# Viewport 0 0#
# Depth 24
# Modes "1440x900"
# EndSubsection
#EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
BusID "PCI:1:0:0"
Driver "fglrx"
EndSection


2 réponses

Cynokine
Messages postés
98
Date d'inscription
mardi 10 juin 2008
Statut
Membre
Dernière intervention
9 février 2011
3
24 janv. 2010 à 23:52
Bon j'ai fini pas résoudre mon probleme seul, pour ceux que ca interesseraient le script qui marche est celui ci :
Code:

#/bin/bash

export JEU_PATH=~/.wine/drive_c/Program\ Files/World\ of\ Warcraft/ # Chemin d'installation de l'exécutable du jeu
if !( ps -e | grep "tty9" ); then #Vérifie l'existence du second serveur X
sudo X :3 -ac -terminate & # Lance sur un nouveau serveur X affichage 3 (Uniquement si il n'est pas déjà lancé)
fi
sleep 3 # Attend 2 secondes que le serveur soit prêt
cd "${JEU_PATH}" # Cible le répertoire de ton jeu
DISPLAY=:3 wine Wo.exe -opengl # Lance le jeu avec Wine et le paramètre OpenGL
sleep 5 #Attend 5 secondes l'arrêt du serveur X
if ( ps -e | grep "tty9" ); then #Si il ne s'est pas arrêté
sudo kill $(ps -e | grep "tty9" | cut -f 1 -d ' ') #Arrête le second serveur X
fi
0
aprenti-linuxien
30 oct. 2010 à 14:11
Slt, quand je fais ton script sa m'écrit sa:

Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
err:systray:initialize_systray Could not create tray window
err:wgl:process_attach X11DRV or GDI32 not loaded. Cannot create default context.
err:module:attach_process_dlls "opengl32.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\wow\\WoW.exe" failed, status c0000142

Help please sa fait des jour que je cherche a faire marcher wow sur mon Linux Ubuntu 10
0