Fonction SI sur excel avec 30 arguments [Résolu/Fermé]

Signaler
-
 pamotte -
Bonjour,

je rencontre actuellement un pb sur la fonction si qui est limité en terme d'arguments (8 max) sur une case comment peut on résoudre ce pb? merci de votre aide

ex :

=SI(P51=1%;AE38;SI(P51=2%;AF38;SI(P51=3%;AG38;SI(P51=4%;AH38;SI(P51=5%;AI38;SI(P51=6%;AJ38;SI(P51=7%;AK38;SI(P51=8%;AL38;SI(P51=9%;AM38;0)))))))))
même en mettanr cette formule j'ai un résultat 0 que faire

5 réponses

Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
2 464
Bonjour,
Si j'ai bien compris tu as :
- cellule P51 un pourcentage. En fonction de cette cellule tu souhaites renvoyer en P53 (par exemple) la valeur contenue dans la cellule correspondante qui se situe entre AE38 et AM38 (au minimum).
Tu peux essayer avec la fonction DECALER comme suit :
=DECALER(AD38;0;P51*100)
P51*100 --->transforme le contenu de P51 (pourcentage) en nombre
5
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57128 internautes nous ont dit merci ce mois-ci

je connais pas la fonction décaler je t'explique ma problématique je dois suivre des indicateurs de serrvice qui en fonction des mois change cad (ex le mois de janvier on doit avoir 95% et le résultat est de 94 delta de 1% ces 1% correspond à une pénalité de 0.7%, 95% vs 90% delta de 5% donc pénalité de 3.3% et ainsi jusqu'à 30% pallier) en mettant la formule ci-dessus j'ai un résultat qui est bloqué "0" et limité à "8" je ne sais pas comment monter cette formule. merci de votre aide
Messages postés
12184
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
31 juillet 2020
2 464
Faisons simple (je n'ai rien compris à votre explication)...
En P51 : un pourcentage (1%, 2%, 3% .... 29%, 30%)
Si P51 = 1% alors je veux la valeur contenue en AE38
Si P51 = 2% alors je veux la valeur contenue en AF38
Si P51 = 3% alors je veux la valeur contenue en AG38
etc etc
Si P51 = 30% alors je veux la valeur contenue en BH38
On se rend bien compte que si on ajoute 1% à P51 on décale d'une colonne vers la droite. OK?
Donc dans la cellule ou l'on veux le résultat il suffit de mettre la formule vue plus haut (=DECALER(AD38;0;P51*100)). Avez vous testé?
Messages postés
304
Date d'inscription
mercredi 21 mai 2008
Statut
Membre
Dernière intervention
18 février 2016
40
Bonjour,

Voici un petit exemple de ce que vous pouvez faire.
https://www.cjoint.com/?blmr2aZ14A

en espérant que cela vous convienne

a+

jéjé
ok super merci encore pour votre aide meilleur voeux