Excel recherche cellule specifique

Résolu/Fermé
vanhoalinh - 4 janv. 2010 à 05:38
 vanhoalinh - 5 janv. 2010 à 03:32
Bonjour,

ce que je souhaite faire est assez simple mais j'ai excel en anglais, et malgre mes recherches je ne trouve pas.

Je voudrais faire une recherche V ou H mais au lieu de me donner le contenu de la cellule, je voudrais simplement le numero de la cellule.

exemple

A B C D E F
1 s d f g g h
2 1 6 7 4 5 5
3
4

si je fais rechercheh("g";A1:F2;2;0) cela va me donner la reponse "4" mais moi je voudrais que cela me donne "D2".

Est-ce possible? cela me parrait simple mais je ne trouve pas de solution, meme en combinant des fonctions (mais c'est en anglais, j'en connais trop peu) donc si quelqu'un connait une solution je suis preneur!

merci ;)

vanhoalinh

2 réponses

eriiic
Messages postés
24431
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 août 2022
7 108
4 janv. 2010 à 07:50
Bonjour,

pour connaitre la position de g en ligne 1 :
=EQUIV("g";$1:$1;0) => 4

et si tu veux l'adresse correspondante en ligne 2 :
=ADRESSE(2;EQUIV("g";$1:$1;0);4)

;4) -> adresse absolue
;1) ou omis -> adresse relative

eric
1
Super merci beaucoup!

ca marche!
Ta reponse m'a egalement permi d'en apprendre plus sur la fonction equiv et index (l'utilite de leur combinaison) en fouillant sur des tutos d'excel (car au debut j'ai du chercher l'equivalence en anglais (c'est MATCH) puis par hasard j'ai lu d'autres astuces)

Dans ce cas precis c'est la fonction ADDRESS qui resout bien mon probleme

merci ;)
0
J'ai une autre question:

Supposons la formule suivante =SUM(A1:A13)

supposons egalement ADDRESS(1;1;4) => A1 et ADDRESS(13;1;4) => A13

pourquoi =SUM(ADDRESS(1;1;4):ADDRESS(13;1;4)) ne marche pas? que faut il faire pour integrer une fonction afin de definir une plage de donnees?

merci

vanhoalinh
0
michel_m
Messages postés
16574
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
3 août 2022
3 278
4 janv. 2010 à 09:37
Bonjour

a traduire en ineugliche
=SOMME(INDIRECT(ADRESSE(2;EQUIV("d";A1:F1;0);4)&":"&ADRESSE(2;EQUIV("h";A1:F1;0);4)))
donne bien 27 svt ton exemple
Indirect (fr)===> indirect (gb)
1
Effectivement ca marche!

super, merci beaucoup!
0
par contre pour que ca marche je n'ai pas mis: &" et "& comme idique dans ta formule. j'ai fait autrement:

=SOMME(INDIRECT(ADRESSE(2;EQUIV("d";A1:F1;0);4)):INDIRECT(ADRESSE(2;EQUIV("h";A1:F1;0);4)))

et il y a quelque chose que je ne comprends pas:


c'est dur a expliquer, je vais reprendre ta formule ce sera plus concret:

=SOMME(INDIRECT(ADRESSE(2;EQUIV("d";A1:F1;0);4)):INDIRECT(ADRESSE(2;EQUIV("h";A1:F1;0);4)))

donne 27

=SOMME(C2:F2) donne 27
en testant la formule INDIRECT a part, si je fais =INDIRECT(ADRESSE(2;EQUIV("d";A1:F1;0);4) cela me donne 6 et =INDIRECT(ADRESSE(2;EQUIV("h";A1:F1;0);4)) cela me donne 5

en remplacant dans la grosse formule on aurait =SOMME(6:5) ce qui ne veut rien dire, alors pourquoi ca marche?

merci ;)

dis moi s'il faut d'autres explications
0
c'est bon j'ai compris en fait!

merci pour la soluce ;)

++
0