Impossible d'installer Mysql

Résolu/Fermé
Signaler
-
Messages postés
30344
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 novembre 2021
-
Bonjour,
J'ai un gros souci avec mysql-server sous débian :/
En effet je tente de l'installer depuis pres de 4h x( je ne sais pas pourquoi, je l'ai téléchargé plusieurs fois, en .deb, en .tar.gz mais rien n'y fais, j'ai toujours le même message qui revient :

debian:/home/a****# dpkg --install mysql-server.deb
(Lecture de la base de donnée... 60373 fichiers et répértoire déja installés.)
Préparation du remplacement de mysql-server 5.0.51la-24+lenny2 (enutilisant mysql-server.deb) ...
Dépaquetage de la mise à jour de mysql-server ...
dpkg : des problèmes de dépendances empêchent la configuration de mysql-server :
mysql-server dépent de mysql-server5.0; cependant :
le paquet mysql-server-5.0 n'est pas installé.
dpkg : erreur de traitement de mysql-server (--install) :
problème de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'éxecution :
mysql-server

si quelqu'un aurait une petite idée, je suis preneur car la je nage :(
Merci d'avance pour vos réponses
Cordialment Sv4r.

6 réponses

Messages postés
30344
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 novembre 2021
7 233
Comme tu le sais sûrement, il existe pour une même distribution plusieurs versions plus ou moins récentes et plus ou moins éprouvées. Les dernières versions de debian sont etch, lenny, et squeeze (ce sont les personnages de toy story).

Au fil du temps la version "stable" correspond à une version de plus en plus récente, en ce moment c'est lenny. On utilise souvent une stable sur un serveur, car c'est la plus éprouvée. Ensuite on peut utiliser des versions plus récentes et moins testées : testing, unstable, voire experimental. En ce moment testing correspond à la version squeeze, et la version unstable s'appelle toujours sid. En pratique une sid marche sans problème.

Actuellement tu tentes d'utiliser le paquet lenny (stable) qui semble défectueux. Dans un premier jet, tente de faire une mise à jour pour voir si ça règle le problème. En root :

aptitude update
aptitude safe-upgrade


Si ça ne change rien, le paquet est définitivement défectueux. L'idée consiste alors à utiliser le paquet d'une version plus récente de debian, en espérant qu'elle fonctionnera. Pour cela, récupère le paquet squeeze (testing) ou sid (unstable) sur :
https://www.debian.org/distrib/packages

En sid le paquet s'appelle mysql-server-5.1 donc lui ne te sauveras pas (car ta dépendance est sur mysql-server-5.0) donc il faut bien prendre le paquet testing, disponible ici :
https://packages.debian.org/squeeze/mysql-server-5.0

Une fois le .deb récupéré, installe-le en root avec la commande :

dpkg -i /le/chemin/vers/le/paquet.deb


Ensuite poursuis ta mise à jour normalement, ton conflit de paquet devrait être réglé, car tu auras installé une version encore plus récente (testing) que celle qui aurait été utilisée en lenny (en stable).

Bonne chance
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Tout d'abord, je tenais a te remercier pour ces informations trés détaillées fournies :)
Je vais donc testé cela dans la matinée et je vous tiendrai au courant ^^

Et encore merci pour ta réponse ;)
Cordialement Sv4r
Messages postés
124
Date d'inscription
mercredi 16 décembre 2009
Statut
Membre
Dernière intervention
14 mars 2013
30
j'ai donc fais comme tu me l'a indiqué, mais j'ai toujours un souci. lorsque je demande s'installer mysql, il me dit qu'il est déja installé. Lorsque je demande de le Désinstaller, il me dit qu'il n'est pas installer x(

voici ce qu'il m'affiche :

debian:/home/agrisvard# dpkg -i /home/agrisvard/mysql-server-5.1.deb
Sélection du paquet mysql-server-5.1 précédemment désélectionné.
dpkg : concernant .../agrisvard/mysql-server-5.1.deb contenant mysql-server-5.1, problème de pré-dépendance :
mysql-server-5.1 pré-dépend de mysql-common (>= 5.1.41-3)
mysql-common est installé, mais sa version est 5.0.51a-24+lenny2.
dpkg : erreur de traitement de /home/agrisvard/mysql-server-5.1.deb (--install) :
problème de pré-dépendance - mysql-server-5.1 non installé
Des erreurs ont été rencontrées pendant l'exécution :
/home/agrisvard/mysql-server-5.1.deb

debian:/home/agrisvard# apt-get remove --purge mysql-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Le paquet mysql-server n'est pas installé, et ne peut donc être supprimé
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Au passage, sous débian il y a-t-il un "synaptic" ? car je ne le trouve pas =/
j'avoue que la, je nage complétement ^^'
Messages postés
30344
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 novembre 2021
7 233
À mon avis c'est parce que tu as pris le 5.1 (sid) au lieu du 5.0 (testing). Or le numéro de version figure explicitement dans la dépendance, donc le 5.1 ne satisfait pas la dépendance. Une idée pour être de migrer toute ta distribution en testing ou en sid si tu ne t'en sors pas de cette manière.

Bonne chance
Probléme résolu :)
Enfaite cela venait des adresses des dépots. Ils étaient en FTP or le firewall leur bloquais l'acces. J'ai donc trouvé les adresses en http, tout est passé nikel, j'ai effectué un apt-get update puis installé le fameux "Mysql" !

Merci pour tes réponses Mamiemando.
Cordialement Sv4r.
Messages postés
30344
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 novembre 2021
7 233
Super, excellente nouvelle et toutes mes félicitations !

Bonne continuation sous linux ;-)