Tranches d'age sur Excel [Fermé]

Signaler
-
 pipofabio -
Bonjour,
J'ai une liste d'age et je souhaites créer des tranches d'age (moins de 30 ans, 30-50, plus de 50ans). Je n'arrives pas à trouver la formule, pourtant ça doit pas être trop compliqué.
Ce serait génial si vous pouviez m'aider.
merci d'avance
marrriooon

5 réponses

Messages postés
121
Date d'inscription
vendredi 16 janvier 2009
Statut
Membre
Dernière intervention
14 août 2011
12
moins de30	                entre 30 et 50	                plus de 50
=SI(C6<30;C6;"-")	=SI(30<C6;SI(C6>50;"-";C6);"-")	   =SI(C6>50;C6;"-")



26
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60919 internautes nous ont dit merci ce mois-ci

Messages postés
16209
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2020
3 031
bonjour à tous
les ages en colonne A
essaies:
=INDEX({"0-30ans";"30-50 ans";"50 ans et plus"};EQUIV(A1;{0;30;50};1))

a recopier vers le bas

tu peux ainsi modifier et/ou les seuils d'age et les libellés
Parfait cet index, merci
Messages postés
121
Date d'inscription
vendredi 16 janvier 2009
Statut
Membre
Dernière intervention
14 août 2011
12
BONJOUR
tu peux créer 3 colonnes et utiliser la formule "SI"
Messages postés
22
Date d'inscription
lundi 30 novembre 2009
Statut
Membre
Dernière intervention
2 décembre 2011
2
bonjour
tu peut utiliser la mise en forme conditionnel
je suis la pour plus de detail
Messages postés
4262
Date d'inscription
lundi 18 décembre 2006
Statut
Membre
Dernière intervention
1 juin 2020
548
Salut !

Que veux tu faire exactement ?
donne un exemple de tes données ,
tout dépend du nombre de tranches d'age , un SI imbriqué peut suffire

age moins de 30 30 - 50 Plus de 50
10 SI(A2>50;"";SI(A2<30;"oui";"")) SI(A2<29,99;"";SI(A2>50;"";"oui")) SI(A2>50;"oui";"")
25 oui
30 oui
31 oui
50 oui
55 oui

tu rempaces oui par 1 ou autre chose à ton gré.

Juste en dessous de ton message tu as différentes façons de calculer un age d'après une cellule où tu as la date de naissance et dans une autre la date d'aujourd'hui .