Problème mot de pass php [Résolu/Fermé]

Signaler
Messages postés
312
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
12 mai 2016
-
 Utilisateur anonyme -
Bonjour,
Je me prend la tête avec une manipulation présenté comme très simple.

J'ai suivi un cour du site du zero pour voir comment protéger une page html avec un mot de passe en php.
j'ai fais un copier collé du code en changeant la partie html par la mienne (la page que je veux protéger) et j'ai ajouté un peu de css pour que ce soit moins moche et j'ai bien sur mis mon mot de passe.

Bref, le premier problème c'est qu'une fois en ligne ou même testé avec Wamp, c'est qu'il m'affiche bien le formulaire pour entrer le mot de passe (avec mon CSS) mais en même temps, il affiche la page que le mot de passe est sencé protéger :S

Le deuxième problème sur lequel je m'arrache les cheveux, c'est que j'essais quand même d'entrer mon code mais quand je le fais il cherche à ouvrir une page protection.php

Le "protection.php" vient du site du zéro (j'ai fais un copier collé) mais de un, c'est écrit nul par dans le code et de deux, il est sencé ouvrir la page qui est codé à la suite.

Bref je comprend rien, si quelqu'un peut m'aider ...

voilà ce que j'ai copier : le site du zero :

<?php
// J'ai choisi le mot de passe "kangourou"
if (isset($_POST['mot_de_passe'])) // Si la variable existe
{
// On se crée une variable $mot_de_passe avec le mot de passe entré
$mot_de_passe = $_POST['mot_de_passe'];
}
else // La variable n'existe pas encore
{
$mot_de_passe = ""; // On crée une variable $mot_de_passe vide
}

if ($mot_de_passe == "kangourou") // Si le mot de passe est bon
{
// On affiche la page cachée.
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">
<head>
<title>Codes d'accès au serveur central de la NASA</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</head>
<body>
<h2>Voici les codes d'accès :</h2>
<h3>CRD5-GTFT-CK65-JOPM-V29N-24G1-HH28-LLFV</h3>

<hr />

<p>
Cette page est réservée au personnel de la NASA. N'oubliez pas de la visiter régulièrement car les codes d'accès sont changés toutes les semaines.<br />
La NASA vous remercie de votre visite.
</p>
</body>
</html>
<?php
}
else // le mot de passe n'est pas bon
{
// On affiche la zone de texte pour rentrer le mot de passe.
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">
<head>
<title>Page protégée par mot de passe</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</head>
<body>
<p>Veuillez entrer le mot de passe pour obtenir les codes d'accès au serveur central de la NASA :</p>
<form action="protection.php" method="post">
<p>
<input type="text" name="mot_de_passe" /> <input type="submit" value="Valider" />
</p>
</form>
<p>Cette page est réservée au personnel de la NASA. Si vous ne travaillez pas à la NASA, inutile d'insister vous ne trouverez jamais le mot de passe ! ;-)</p>
</body>
</html>
<?php
} // Fin du else
// Fin du code :)
?>

6 réponses

Messages postés
784
Date d'inscription
vendredi 26 juin 2009
Statut
Membre
Dernière intervention
21 janvier 2010
55
<form action="protection.php" method="post"> <------ si ici

Je ne vois pas le problème, cette page marche correctement, du moment qu'elle s'appelle protection.php. Remplace tous les "protection.php" par le nom de ta page et remplace le truc de la nasa par ta page à protéger...
As-tu essayer de le faire tel quel sans modifes ? Et est-ce que ça à marché ?
Messages postés
312
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
12 mai 2016
5
ben oui le code tel quel fonctionne. C'est celui présenté sur le site du zero. Et j'ai essayé ce code sur Wamp et il marche.

Je ne voit pas pourquoi le mien ne fonctionne pas :(

Néanmoins, merci resalut j'ai remplcer "protection.php" par "index.html". pffff, je l'ai relu je sais pas combien de fois je l'ai loupé à chaque fois :D

Il me reste donc un problème : quand je lance la page elle affiche à la fois le formulaire et en dessous la page que le formulaire est censé caché. Et je ne comprend pas pourquoi !! :(
Messages postés
784
Date d'inscription
vendredi 26 juin 2009
Statut
Membre
Dernière intervention
21 janvier 2010
55
change l'extension html par php ....
Messages postés
312
Date d'inscription
mercredi 23 septembre 2009
Statut
Membre
Dernière intervention
12 mai 2016
5
yeaaaaaaa

merci ca fonctionne Resalut !

mais du coup, j'ai une question qui me vient à l'esprit.
Es ce que dès qu'il y a le moindre petit code php (comme un compteur de visiteurs par exemple) on doit mettre l'extension .php ou es ce que parfois, on garde .xhtml ?

Et comment savoir si c'est php1, php2, php3, ... ?
merci

Tu créé à la racine un fichier nommé ".htaccess" (je sais, c'est biz), tu y insert cette ligne :
AddType application/x-httpd-php .xhtml

C'est sensée bien marcher, dès le moment où tu as apache.