Excel: attribuer pourcentage case

Résolu/Fermé
Signaler
Messages postés
13
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
17 novembre 2009
-
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
-
Bonjour,
Je souhaite attribuer un pourcentage à un ensemble de case. Je m'explique:
Par exemple,j'ai une colonne A qui, si je mets un 'X' dans la case de cette colonne, cela équivaut à un pourcentage de complétion de 50%. Si j'ai une colonne B qui, si je mets un 'X' dans la case de cette colonne, cela équivaut à un % de complétion de 5% etc

Comment est-ce possible?
Voir exemple ci-bas pour éclaicissement

Merci beaucoup

EXEMPLE:

Colonne A Colonne B Colonne C Complétion
50% 5% 10% %

X X 55%
X 10%

etc

13 réponses

Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
777
bonjour,

si j'ai bien tout compris :

hypothèses de l'exemple :
ligne 1 : 50% ; 5% ; 10%
ligne 2 : saisie des "x" par colonnes
ligne 3 : ... // .......... //............
....

dans la colonne complétion :

{=SOMME(SI(A2:C2="x";$A$1:$C$1))}

formule matricielle, écrire la formule sans les { } et valider pour sortir en faisant CTRL+SHIFT+ENTER, les { } se mettront automatiquement.

puis étirer la formule pour la recopier vers le bas si nécessaire.
Messages postés
13
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
17 novembre 2009

Ok,mais comment faire l'addition des pourcentages?
Par exemple,si je mets un X à la ligne 2 de ma colonne A (50%) et de ma colonne C (5%), alors, le total des %tage de ma colonne complétion doit être 55%...
Tout ca,dans le but de faire un tableau de complétion de tâches.Quand ma tâche de la colonne A va être faite, alors je mettrai un 'X' ce qui indiquera que cette action à la ligne 2 est complétée et que cette action compte pour 50% de la tâche au total.

oufff,j'ai l'impression de ne pas être clair haha
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
6 131
Bonsoir
peut être simplement avec:
=SI(A2="X";50%;0)+SI(B2="X";10%;0)+SI(C2="X";5%;0)
non?
crdlmnt

Messages postés
13
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
17 novembre 2009

C'est exactement ca Vaucluse!!!
Merci beaucoup!
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
777
bonjour,

c'est aussi ce que fait la formule du post 1..
Messages postés
13
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
17 novembre 2009

Bonjour Dobo69,
en effet,je me suis rendu compte que ta formule fonctionne également.Un gros merci

Maintenant,j'ai encore besoin de faire un autre petit calcul. Est-il possible de mettre une photo sur ce site?De cette facon,ca serait beaucoup plus simple à expliquer..."Une image vaut milles mots"


Merci
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
777
tu ne peux pas mettre de photo directement sur le site.
En revanche, tu peux déposer à ce lien n'importe quel fichier (soit une image sot directement ton fichier excel par exemple...). Lors de la dépose, Ci-joint de donne un lien : copier coller ce lien dans ta prochaine réponse.
Messages postés
13
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
17 novembre 2009

Excellent,
En gros,ce que je veux faire,c'est que je veux faire la moyenne de la colonne "Complétion" en fonction de l'Aréa (par exemple,Aréa 302, 112 etc)
Donc,si ma colonne Aréa = 302, alors faire la moyenne du total de chaque ligne 302 de la colonne complétion.

Pour être plus clair,j'ai mis une photo de mon tableau à cette adresse.

http://www.cijoint.fr/cjlink.php?file=cj200911/cijK6QLsEQ.jpg

merci beaucoup
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
6 131
Bonjour
si votre champ AREA
de A2 à1 A000
votre champ Complétion de G2 à G1000:
=SOMME.SI(A2:A1000;302.G2:G1000)/NB.SI(A2:A1000;302)
vous pouvez bien sur rremplacez 302 par l'adresse d'une cellule où vous placerez le code concerné;
vous pouvez aussi arrondir le résultat à un nombre dce décimale choisi:
soit:
=ARRONDI(SOMME.SI(A2:A1000;302.G2:G1000)/NB.SI(A2:A1000;302);2) qui vous donnera 2 décimales.
ARRONDI.INF arrondi à l'inférieur
ARRONDI.SUP au supèrieur
ARRONDI au plus proche
Crdlmnt
PS pour être plus complet au vu de votre tableau:
vous pouvez remplir directement le cartouche à droite en l'état si vos codes ont tous 3 chiffres, avec u cartouche supposé de H3 à I7
en I4 en face de AREA 302:
=ARRONDI(SOMME.SI($A$2:$A$1000;DROITE(H4;3);$G$2:$G$1000)/NB.SI($A$2:$A$1000;DROITE(H4;3));2)
Cette formule prend les trois caractère à droite de la cellule indiquée
Bonne journée
Messages postés
13
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
17 novembre 2009

un gros merci!
ca fonctionne à merveille.
Petite correction pour que ca fonctionne:
Mettre un ";" ou lieu d'un "." après le 302

vaucluse: =SOMME.SI(A2:A1000;302.G2:G1000)/NB.SI(A2:A1000;302)
Joe_Blo: =SOMME.SI(A2:A1000;302;G2:G1000)/NB.SI(A2:A1000;302)

Merci encore!
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
6 131
Exact
Une faute de frappe, ça arrive souvent chez moi!
Crdlmnt
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
777
vaucluse, Joe_Blo,

je m'excuse de reprendre le fil maintenant et d'interférer :
j'avais compris que la moyenne ne tenait pas compte des valeurs nulles c a d des lignes non remplies (cf AREA 302 dans le tableau joint : Moy = 33.75, soit moyenne uniquement des valeurs non nulles de 302).

Dans ce cas la moyenne doit se faire sur 2 conditions et à part une matrice, je ne vois pas d'autre solution que cela :

{=SOMME(($A$2:$A$1000=DROITE(H4;3))*(G$2:$G$1000<>0)*$G$2:$G$1000)/SOMME(($A$2:$A$1000=DROITE(H4;3))*($G$2:$G$1000<>0))}

toujours la même chose : formule à rentrer sans les { } et sortir en faisant CTRL+SHIFT+ENTER, puis étirer ves le bas pour les autres moyennes
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
6 131
Bonjour tous
Aucn problème pour moi dobo, l'essentiel restant que le demandeur aie une réponse edfficace le plus rapidement possible.
Tant que le fond reste excellent comme dans tes interventions, il n'y a aucune raison de s'offusquer de la forme.
Bien amicalement.
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
777
et même pour traiter les AREA "vides" :

{=SI(SOMME(($A$2:$A$1000=DROITE(H4;3))*($G$2:$G$1000<>0))=0;;(SOMME(($A$2:$A$1000=DROITE(H4;3))*(G$2:$G$1000<>0)*$G$2:$G$1000)/SOMME(($A$2:$A$1000=DROITE(H4;3))*($G$2:$G$1000<>0))))}
Messages postés
13
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
17 novembre 2009

Dobo69,
j'essaie de comprendre ta forumule (je suis loin d'être un pro dans excel) et je ne comprends pas ta matrice.
Que veux dire "DROITE(H4;3)"?

merci
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
777
DROITE(H4;3) renvoie les 3 caractères de droite de la cellule H4.

Dans la formule, cela permet de récupérer le N° de de l'AREA pour lequel on fait la moyenne :
dans le tableau que tu as joint en post 8, il est écrit dans la cellule qui nous intéresse : "AREA 302" par exemple. Nous avons besoin de récupérer "302" pour le rechercher dans le tableau des données d'entrées.
Messages postés
13
Date d'inscription
mardi 3 novembre 2009
Statut
Membre
Dernière intervention
17 novembre 2009

ok,
je ne savais pas que le 3 prenait les 3 caractères de droites
le tout fonctionne parfaitement!
merci!